Firmware Updater


I updated my Mk3S to 3.7.2 and now i cant select German as language. If i select he load but switch back to the select language window. When i choose English all fine.

Some idea ?

thx best regards

Have you tried to clear your browser cache and/or use a different browser?

1 Like

Hi @Amutep!

You are talking about the OctoPrint web front end or the language on the printer display?
Because updating the printer firmware does not affect the language of OctoPrint.

@PrintedWeezl sry maybe you misunderstood or i :smiley:

@Ewald_Ikemann no no i talk about the language on printer display.
After the update the printer restarts an then i can at the printer display choose a language if i select german he loads a few seconds then he jump back to the language list then i select english load a moment amd all fine.

Well you didn't specify that you mean your printers language so assumed you meant the octoprint language.
You know because you're on the octoprint forum :wink:

I don't know Prusa printers myself but I see there are different firmwares in different languages. For example prusa3d_fw_MK25S_3_7_2_2363_RAMBo10a_en-de.hex. Did you flash the right one?

if you flashed the right one I would try to reset the eeprom. Maybe something went wrong between the older and the newer firmware.

Be aware that this resets all settings you have done on your printer.

If that still doesn't help and nobody got another idea I would suggest you ask the guys on the prusa forums

Good luck :slight_smile:


sry for that.

there is only one firmware file that i can use so i think i used the right one =)

i flashed firmware second time via octoprint no german language work

so i tried with cable direct on my pc via slicer pe and no problem flashed firmware select german and it works