I'm running 1.3.8, I get an update error when trying to update to 1.3.9


#1

The update did not finish successfully, what is the issue?

octoprint.log:
TypeError: init() got an unexpected keyword argument 'async'

plugin_softwareupdate_console.log:
c:\octoprint\venv\scripts\python.exe -m pip install https://github.com/foosel/OctoPrint/archive/1.3.9.zip

thanks
Davide


#2

This should help:


#3

followed the indicated procedure, but continues to give the usual error as I try to update to version 1.3.9