Temperature Failsafe Pluggin not working since Octoprint Update 1.3.11

#1

**What is the problem?**Since I've updated to Octoprint 1.3.11 the pluggin "Temperature Failsafe Pluggin" always faults out once I start a print. This problem started as soon as I updated to 1.3.11, been running all of my pluggins for months with no issues.

What did you already try to solve it?
Went back to a backup image on my sd card which was using Octoprint 1.3.10 and issue was not there, back to 1.3.11 and issue returned. My workaround for now is to disable the "Temperature Failsafe Pluggin"

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Using a Creality CR-10s Pro, TinyMachines firmware B6

#2

Sounds like your CR10S Pro doesn't have an enclosure but your profile thinks it does (guessing here). It's trying to get the temperature of the enclosure and interpreting None as a number which is less than 15 degrees Celsius.

It's possible that your printer's profile needs to be adjusted to indicate that it doesn't have an enclosure or if it does, perhaps the thermistor or similar is disconnected.

#3

Post your octoprint.log.

#4

So, how do I tell octoprint that I don't have an enclosure temperature? This seems to be something new that is happening with the latest version 1.3.11. Is there now a setting that I can tell octoprint that there is no enclosure? Thanks so much in advance!

#5

octoprint.log (28.4 KB)

#6

I cleared out the old log and so it just has the current run with the error, if you need the old log file, I can send that too

#7

Thanks for clearing out the log and running it. The error is in there, and it's certainly at an aggravating time- after you start a print.

2019-05-18 02:45:02,991 - octoprint.plugins.excluderegion - INFO - Event received: event=PrinterStateChanged payload={'state_string': 'Printing', 'state_id': 'PRINTING'}
2019-05-18 02:45:05,080 - octoprint.util.comm - INFO - Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
2019-05-18 02:45:05,396 - octoprint.plugins.TemperatureFailsafe - ERROR - TemperatureFailSafe violation, heater: chamber: NoneC < 15C
2019-05-18 02:45:05,403 - octoprint.plugins.TemperatureFailsafe - ERROR - Canceling print

~ccing foosel;~

I don't know why it's getting None instead of ignoring the chamber, there isn't enough info for a full bug report but there's definitely a problem. That plugin has been stale for two years; I submitted an issue you'll probably need disable the plugin.

(edit- oops, I thought that was the built-in safetycheck. This isn't foosel's problem.)

1 Like
#8

Well, I'm sure it could be resolved by the maker of the pluggin, but the problem started with the Octoprint Update so I thought that might be a good place to start! Thanks!