About Plugin Tutorial

I'm trying to follow the tutorial from the beginning. In my desktop PC -running Ubuntu 18.04- I open a terminal and:

mkdir devel cd ~/devel
git clone https://github.com/OctoPrint/OctoPrint [...] cd OctoPrint
$ virtualenv venv

Oops! virtualenv command is not installed, so I run:

$ sudo apt install python3-virtualenv

but nothing changes.

:thinking: I'm very confused

try sudo python3 -m pip install virtualenv or pip install virtualenv?

I've just tryed with

sudo apt-get install python-virtualenv virtualenv

It seems that works OK.

Make sure that's using Python 3 and not Python 2. I might take a look at the docs.octoprint.org instructions and make sure they're not out of date, since it is easier to use python3 -m venv venv - virtualenv, by default will always use the Python 2 install :slightly_frowning_face:

You are right. Running
$ virtualenv venv
I get "Running virtualenv with interpreter /usr/bin/python2..."
so I run
$ python3 -m venv venv
and now octoprint serve reports:

INFO - Detected environment is Python 3.6.9 under Linux (linux).

it would be nice to include a note on the Tutorial page, warning Ubuntu users of those changes

Great that you got it up and running. All the install guides are up-to-date, but some of the stuff on the documentation is less looked at. Will add it to my list of things to do on the docs :slightly_smiling_face:

It's not just Ubuntu users that will be caught out by this - Python 2 is being dropped by many distros now, for example in Debian 11 (bullseye) & in Ubuntu 20.04 I don't think Py2 is even available through apt anymore. Can definitely get confusing, will switch it over to using python -m venv asap.

Thank you for your work.
For my part, I will continue studying the tutorial. :nerd_face: