Add support for raspberry pi camera V3

Add support for raspberry pi camera V3


I'm assuming that camera is supported in the newer bullseye raspberry OS, which the Octopi 1.0.0rc4 version is based on. You will still more than likely have to install a different streaming service on the pi, like camera-streamer or go2rtc because of the IMX chipset.

I've been 2 days trying to configure this camera for Octoprint and I've been unable, both as in the stable version as in the bullseye based nightly, I've tried different ways and solutions like the camera-streamer and I can only get it to work in the terminal, but not in Octoprint, has anyone got something else?

If you get it working in terminal I wouldn't think it would be that difficult to get working in the OctoPrint interface. You will definitely have to disable the webcamd service for starts. I know Char in the OctoPrint Discord server got it working with an IMX219 camera.

This guys instructions worked for me.


is there some update about support of raspberry pi camera V3?
I saw some note in New OctoPi Release: 1.0.0 ( Please note that OctoPi 1.0.0 does not yet include support for the new Raspberry Pi Camera v3. However, we are actively working on a webcam stack swap that will allow us to support libcamera based cameras like that one and also newer Arducams. A test image built on top of OctoPi 1.0.0 via OctoPi-UpToDate with that should hopefully be available within the next two weeks!)

Thank you for your feedback.

I am waiting for if because i buy my first rapsberry with this cam V3.

You can find the mentioned testing build in the below issue:

It's progressing well so far, in my opinion.

1 Like

Hi All,

Is the Raspberry cam 3 now supported in octoprint ?

The testing image is here:

To actually answer your question, no, not yet but apparently soon. There are still issues being worked around in the testing image. You can follow the progress at that link.

Do you mean the link posted by Charlie_Powell? Looks like that has been closed, but I still can't get the RPi Cam v3 to work under OctoPrint 1.9.0 (installed via OctoPi v1.0.0, a week ago). As that discussion is closed, I can't comment any further on it, so figured I'd ask here if support for the camera is now working before I submit a bug report...


Which one? the one with the old or the one with the new camera stack?

Uhh, I don't remember there being a "new camera stack" option in the Raspberry Pi Imager, although I admit it I don't remember much when I did it anyway.

Is there a way of finding out what I've done (e.g. within Octoprint or via SSH) without having to reinstall everything from scratch?

For what it's worth, the camera has worked intermittently, but mostly hasn't worked. Sometimes when I boot Octoprint, the camera is working, but most times it's just a black camera feed.

Update, ten minutes later: I have found it.

  1. In Octoprint, open the Settings menu.
  2. Click "System info" down the bottom.
  3. Click "Download Systeminfo Bundle" button.
  4. Extract the ZIP file and open systeminfo.txt.
  5. The version number for the line that begins with env.plugins.pi_support.octopiuptodate_build: is what I needed to check.

I have version 1.0.0-1.9.0-20230523082504, which I note from the screenshot of the Raspberry Pi Imager is the version without the new camera stack.

I also note in the comments on that article that it is not possible to easily upgrade to the new camera stack, and it is easier to just start all over again with a fresh install of the image. So I shall do that.

Thank you all for your help.

1 Like

you can create a backup and perform restore during initial setup wizard after flashing. just make sure to download it first...

1 Like

Thank you. I have done so and can confirm the new v3 camera is working perfectly with the new camera stack version of OctoPi.

Thanks for the help to you both.