After the update to 1.5.x I keep running into SerialExceptions

We have been following this thread hoping for a solution (sudo update didnt work). We are using a BTT SKR Pro 1.1 on Marlin 2.0. We can find no reference to the USE_USB_Composite macro so am not sure where to add that to try it(conf.h or adv.h ?).

The strange thing is ANY new ISO works fine (no serial exceptions) in our RP 1B+ v1.2, but throws serial exceptions in our new RP 4B.

The 1B+ is slow but it connects just fine.

Is that a clue to what may be happening?

USE_USB_COMPOSITE is set in platformio.ini, it's set for some of the btt environments (set in default_envs in the [platformio] section). Depending on which one you use you may want to try commenting it out.

Hello everyone,

Apologies if this should have been posted as a new topic. I think this appears to be related?

Thank you for this thread, it has been a huge help in my troubleshooting. I am new to 3D Printing and to RPi so am learning as I go.

I have been experiencing this issue and have tried all the suggested fixes. Unfortunately, none have worked for me so far.

My details are as follows:

Printer: Ender 3 V2 with 4.2.7 mainboard

Octoprint Version: Initially 1.5.2, updated to 1.5.3 during troubleshooting
Octopi Version: 0.17.0, updated to 0.18.0 during troubleshooting
System: Raspberry Pi 4 Model B (Pi NOIR Camera module V2 connected)
Browser: Google Chrome Version 88.0.4324.150 (Official Build) (64-bit)

Experiencing the SerialError at random during prints longer than 60 minutes.
X,Y and Z stepper motors stop moving, but the hot end and bed stay at their assigned temperature. I have to reconnect to turn off the temps.

Firmware Tested:
Creality V1.0.1
Bugfix 2.0.x.x (15 Feb, 16 Feb and 17 Feb)

Troubleshooting Fix? Actual result
Moved closer to GPO (removed extension cable) No Failed after 60 minutes
Swapped USB cable No Failed after 60 minutes
Printed directly from SD card No Caused Screen to lock up, so had to cycle power of the printer
Covered 5v pin of USB cable No Failed after 60 minutes
Ran in Safe mode No Failed after 60 minutes
Connected Printer to UPS No Failed after 40 minutes
Printed a shorter print (Less than 60 minutes) Yes Successful for 4 different models
Rolled back to Creality V1.0.1 No Failed after 20 minutes

I've uploaded the Octoprint.log to my Google drive as it was too large to upload here.

I thank you for ready through this wall of text, I hope I have given enough information.
serial (8).log (2.5 MB)

Did you have OctoPrint connected when you printed directly from SD card? If it also failed then, something is up with your hardware.

Thanks for the reply!
Octoprint was not connected when printing directly from the SD card. Would you suggest trying another board?

Yeah, since you've already pretty much ruled out firmware as a possible cause. If OctoPrint's not in the mix and your printer still doesn't print reliably, the fault can't possibly be with OctoPrint and is most likely with the firmware or the printer itself if just printing from SD won't even work.

Thankyou Gina,

I've ordered a new board. Will report back once that is installed :slight_smile:

Just reporting back that replacing the board with a brand new 4.2.7 has fixed my issue.
Thanks again!

1 Like