All Filament Sensor Plugins Do Not Work Anymore

No filament sensor plugins work now, even though the GPIO pins are verified to respond correctly to the filament sensor microswitch. I have confirmed this via SSH and the command 'gpio readall'. The pin goes from low to high when filament runs out, therefore the sensor is operating correctly and the pin is being read correctly by the Raspberry Pi. Even though the pin responds correctly, neither "Filament Sensor Reloaded" nor "Filament Sensor NG" pause the print even though they are configured completely correctly.

I am on the latest version of OctoPi. Is this an issue with new versions of OctoPi? Does someone need to create a new updated version of a filament sensor plugin?

If you are on the latest version of OctoPi, I urge you to test these filament sensor plugins and report whether they work for you or not. This is a big issue, since there currently appears to be no way to have a filament sensor working with OctoPi.

Have you tried Enclosure plugin?
It works fine for me with a momentary switch to turn on/off the light on the printer witth OctoPrint 1.3.12

3 Likes

I have not tried Enclosure plugin. Can this plugin be rigged up to pause the print when a filament sensor is triggered? If so, I will give it a try as soon as I have time.

Yes it can. On my last printer I used it for just that purpose.

2 Likes

The Enclosure plugin is working great! Thank you so much for your recommendation! :slight_smile:

2 Likes

None of them are working for me either.

I'm trying to get the enclosure one working but that also seems broken.

For reference, I'm using an RPI4, and the triangle labs sensor.

I've tried using Pin 7 (GPIO4) and Pin 11 (GPIO17).

Looks like I will have to give up on octoprint and compile the sensor into marlin sigh

I have also been trying the new Filament Sensor Revolutions plugin that was released at the end of November -- NO LUCK with it either. I have determined that the sensors operate correctly (using the provided API for checking sensor status via GET). With much experimentation I determined that if the filament out sensor is definitely checked when a print is starting (e.g. no filament loaded will cause the print to abort), however it doesn't ever seem to be checked after the print is running. I wonder if the I/O pins are ever being polled once the print is in progress.

I will have to give the Enclosure Plugin a try.