Bad connection to octopi

What is the problem?
When printing or uploading a file to the printer it will work for approx 2 seconds then it will freeze for a minute.

What did you already try to solve it?
Tried updating octopi using sudo apt-get update / upgrade.
Tried changing baud rate when connecting.

Additional information about your setup

Using OctoPrint version 1.3.4
Using OctoPi version 0.14

This is what I'm getting from the terminal tab when it unfreezes:

Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Send: N3617 M105*20
Recv: Error:No Checksum with line number, Last Line: 3615
Recv: Resend: 3616

What printer model? Original Prusa by any chance? The missing ok after the resend request sounds like it. If so:

Also: update your OctoPrint ASAP

It is an UniCubic U1. Its a Prusia i3 style printer.

Create a serial.log and post it here.

Here os the serial log serial.log (25.3 KB)

Looks like some severe communication issues with your printer, it keeps complaining about lines that are sent correctly.