Bed Visualizer Crashes Printer Only certain circumstances

Very weird stuff going on. First here is my environment:

I have an Ender 3 V2 Running Smith3d Marlin 2.0.x.14 and Octoprint OctoPrint 1.4.2 Python 3.7.3 OctoPi 0.17.0

  1. If I start the printer then boot my octopi raspberry pi and connect (it's automatic) and then try to update mesh under bed visualizer nothing happens unless I home the extruder head first. Not a big deal but thought I should mention.

  2. If in octopi (web interface) I select a preset temperature profile then go to bed visualizer and click on update mesh it gets about halfway through then crashes printer and printer panel freezes. It looks like octopi.local is still up but even if I reboot printer I can't reconnect I have to restart octopi also.

If on the other hand I select temperature profile in octopi let the printer get warm and toasty and then shut off the temperature profile, I can then update mesh under bed visualizer.

Here are some log files. Any help or insight would be appreciated.

octoprint.log (140.2 KB) serial.log (24.7 KB)

You first have to wait until the temperatures reached their aim, then start the levelling.

2020-11-23 21:06:38,494 - Send: M140 S70
2020-11-23 21:06:38,502 - Recv: ok
2020-11-23 21:06:38,531 - Send: M104 S180
2020-11-23 21:06:38,541 - Recv: ok
2020-11-23 21:06:40,022 - Recv:  T:86.29 /180.00 B:37.31 /70.00 @:127 B@:127
2020-11-23 21:06:42,021 - Recv:  T:85.54 /180.00 B:37.67 /70.00 @:127 B@:127
2020-11-23 21:06:43,353 - Send: G29 T
2020-11-23 21:06:44,021 - Recv:  T:85.68 /180.00 B:38.04 /70.00 @:127 B@:127
2020-11-23 21:06:45,405 - Recv: echo:busy: processing

So use M108/M190 instead of M104/M140

Sounds like a firmware bug to me...

Feature in the firmware usually, no movement until printer is homed. Can be turned off.

Seems the firmware struggles to sort out both temperatures and levelling at the same time. Is the Ender 3 V2 a 32bit board.

Thanks for the explanation good to know. Yes its a 32bit board.

In that case, it should handle it fine. I would report the issue upstream to the people making your firmware (since I notice it is a fork of Marlin)

Thanks for the quick response! Will try adding M108 and M190 before the mesh update

Sorry, not M108 it's M109

1 Like

Ok that makes sense. I will try.

Wow! I think that fixed it. I tried two separate print jobs setting temp first, then running Bed Visualizer, then the job. No crashes.

Thank you!

1 Like

Thanks for the quick response.

1 Like