Bed Visualizer doesn't recognize correct bed size

So I have a problem that I absolutely cannot solve. I think it might be tied to the leveling of the bed. I cannot get my first layer to stick anymore.

I have an ender3 with silent board and CR Touch. I had everything setup correctly and I changed the bed springs. I decided to try Bed Visualizer after to help me with leveling. Now I can't figure out whats happening.

I have my XY Offsets at -46 and -6 based on the measurements I took. I put them in based on the controls on the printer. I verified those by checking the 851 command on the terminal in octopi.

My ZOffset was set by homing the printer and then slowly lowering the nozzle until a piece of paper is tight but not too snug. It was -0.65. I set the Z Offset and saved. Now when I home it raises the to Z10.65 instead of Z10.

I ran the bed visualizer and its really level according to the photo. Problem is that it probes incorrectly. Probe point 1/9 is barely on the bed but the display shows it as X56. Probes 3, 6, and 9 show it as X235 but its not even really near the right side of the bed. Clearly its thinks its probing certain spots but its not really correct.

When I slice in Cura, I was setting ZOff and the object would be centered. When I print, it prints way off. I moved the object in Cura -46 and -6 and Cura shows it at those coordinates but when I print, it would be dead centered. I tried it with the XY OFF set in cura but someone suggested removing those because I don't need it. As long as my firmware has it, its good. I thought that would correct everything but my first layer still sucks. The rest of the print is fine but the first layer is not doing what it should. I have slowed down the first layer, raised bed temp, raised nozzle temp. It still looks exactly the same.

Somewhere along the lines, the bed size got thrown off and something thinks the beds size is way different. Nevermind the CR Touch to Nozzle. The entire bed is way off. How do I tell the bed visualizer where exactly the probe points are and that my bed is 235x235 but print area is 220x220?

Sounds like you have your printer profile in OctoPrint set to a center origin instead of lower left?

No, I just double checked that. Its not set to center.

I think i've figured out the main cause for the bed size. The CR Touch hits the X Stop Switch on the left side. When it hits the switch, it obviously cant go any further. I can't physically move the nozzle to the far left. I checked the right side and when the nozzle is on the very far right side (should show X235) its actually X229. I think that means the settings thinks that XY 0,0 is actually 6,0. I am not sure how to fix this.

I changed my XY offsets backt o 0,0 and moved the nozzle as close I could to 0,0. It looks like its actually at 2,2 when my screen shows 0,0. I Tried to go in and set Home Offsets from that point and I got an ERR : TOO FAR error. Im not sure what that means.

You may find this post helpful. As for the ERR : TOO FAR error, that also relates to the configuration of the firmware and bed limits.

I got that corrected.

Seems like you are the developer? I have another question if you don't mind.

How do I set the plugin to check a 5x5 grid as opposed to the standard default 3x3?

I am. Plugin doesn't control that, it's a firmware setting that requires recompiling and flashing.

Thanks for the reply. Over my head for right now. Ill stick to the 3x3.


I have the same problem here.

Got 2 FDM printers, Ender 3 and Ender 5+ (E5+)
The ender 3 works fine on the bed visualizer, but the E5+ keeps doing the same problem over and over.

Let me try to describe this:

1- All is set as default (start at the lower left)
2- i home the printer in the printer panel before i start anything
3- on the bed visualizer now: when it starts it homes right to the midle, but then he does not go to the the 1st reading point. goes into half the bed and starts from there.

i have used this plugin since it exist... but now something is wrong on my printer or in the plugins/octoprint. so i am asking after checking cables and settings... what can be causing this?

im starting to look into the hardware and the electric voltage but... that will take some time................ if it is the power grid...

The plugin doesn't control the actual probing the printer is doing. You set that in the gcode script in the plugin's settings, and the rest is controlled by the firmware on the printer.

hum.... thanks.
that was i tought in the first place. the octopi gcode. i tried to change it, but still does not make sense to me, i use the same client for the 2 printers (one each time). same gcodes and they worked fine before.
the gcode im using is the default one from cura atm, before i had one that i have found around forums for the enders and my "hardware". BLtouch on the 2 printers so they should share most of it.

but i will dig a bit further on the gcode too. but i will call it for today, or im gonna start pulling hair hehe

maybe is something else, thats why im here. trying to get someone attention that had the same problem before. Or open a case of study =p