Bed Visualizer - Installation issue

I recently updated octopi from scratch and went about with installing the plugins that I had on my previous installation and Bed Visualizer plugin completes installtion but shows up as "Unknown". After rebooting the RPi3, It doesn't appear to be running and doesn't appear in the plugin manager.

The only way I know it installed if when I issue the following command "~/oprint/bin/pip list" and it's on the list.
I have only been able to uninstall it via the following command "~/oprint/bin/pip uninstall Bed-Visualizer" and everytime I install it from the plugin manager I get a successful install prompt but OctoPrint pop-up shows Successfully installed: Unknown

I'm not sure how to address this issue. Can anyone help

When you type the command ~/oprint/bin/pip freeze is numpy listed in the installed packages? The only reason I've seen my plugin have issues installing is when numpy isn't able to compile properly.

Using the command ~/oprint/bin/pip freeze

I see numpy listed:

numpy==1.16.5

Very odd then. Try installing the plugin again and check the logs for errors afterwards.

It actually says successfully installed but the plugin is "Unknown"
I'm going to try to install OctoPi again and install the Bed Visualizer plugin to see if anything changes.

Will report back any changes

Yeah, usually when it reports Unknown like that there is an error in the background/logs that will indicate why.

Full reinstall of OctoPi followed by plugins appears to have worked.

2 Likes