Bed visualizer plugin error


#1

I'm having a problem with the bed visualizer plugin. It's generating an error when attempting to generate a mesh...
I have installed it on two different Raspberry Pi computers with 2 different installations of Octoprint. It worked when I last used it with my laptop using Google Chrome as my browser.
Now, I'm trying to access it with my desktop computer and it generates the error:

GLError: gl-shader: Error linking program: Vertex shader sampler count exceeds MAX_VERTEX_TEXTURE_IMAGE_UNITS (0)

The instructions at the top of the error message box say:
Bed Visualizer Error
Looks like your settings are not correct or there was an error. Please see the readme for configuration hints.

I'm at a loss here... I've also tried to uninstall it and although it appears to get uninstalled, it never gets removed from the list of installed plug-ins and I can't reinstall it...


#2

I'm sure the author would love to know which operating system and browser is on your laptop.

This sounds pertinent.

@jneilliii

Looks like it would also be good to know your GLSL version.


#3

Yes, definitely would need to know browser you are using. To me that almost seems like a graphics driver related issue, make sure your graphics card drivers are up to date as well.

As to the uninstall, the plugin is working as expected but the plotly library is choking up on the visualization side so don't think it's necessary for you to uninstall/reinstall. Not sure why it's still showing up after uninstall though, possibly a force refresh of your browser by holding down the CTRL key and pressing F5.


#4

How to upgrade GLSL version


#5

The browser on my laptop was Google Chrome and it worked fine. The browser on my desktop is Google Chrome as well. As far as I know the graphics drivers on my desktop are up to date, but I'll check them tonight. The video card is an NVidia card and the computer is only about 3 years old, so it's not something that is out of date. OS is Windows 7 Professional 64 bit, same as the laptop. I have gone through the Uninstall process for the bed visualizer plug in, but now I cannot RE-INSTALL it. It still shows up in the list of installed plug-ins and this is an issue on 2 different Octoprint installations in 2 separate Raspberry Pi computers.


#6

This could be related to a pip issue I've seen in the OctoPrint issue tracker floating around. Seems a certain version of OctoPi was released with an upgraded PIP that caused problems. You'll probably have to manually go through the process of cleaning it out unless @OutsourcedGuru has a better idea. First SSH to your pi and then run the following commands.

cd ~/oprint/bin/
./pip freeze

The last command will generate a list of all installed packages. Looks through that list for anything related to BedLevel-Visualizer. In my case it shows up like this.

backports.ssl-match-hostname==3.5.0.1                                           
Bed-Visualizer==0.1.2                                                           
blinker==1.4   

Once you've found that name you would run the following command to force the uninstall.

./pip uninstall Bed-Visualizer

You will be prompted to confirm, just enter y for yes.


#7

I was finally successful in uninstalling and then Re-installing Bed Visualizer plugin.
My OpenGL version is 2.1 and my graphics card is the nVidia GeForce 7900 GS

My video drivers are up to date and I'm still not able to use the Bed Visualizer
V


#8

Can you grab the bed visualizer plugin settings from your config.yaml and post them here using the preformatted text button above please.

image


#9

Also, any relevant information in octoprint.log that would point to any plugin errors.