Bed Visualizer Plugin


#1

I'm getting the following error message when the BedVisualizer Plugin finishes its probing to obtain the mesh. No graphic is displayed.. How can I fix this. The README file is of no help.

GLError: gl-shader: Error linking program:VERTEX shader texture image units count exceeds MAX_VERTEX_TEXTURE_IMAGE_UNITS(0)


#2

Need more information to help you @benebrady. What is your firmware, what do you have configured in settings, what is showing as being your stored mesh data, what browser? Any other errors in octoprint.log? The specific error indicates a webgl issue, which is tied to graphics card drivers and the plotly library I use to do the work in the plugin.


#3

Also, you had this issue before, why the duplicate post? and reinstalling you said fixed the issue. Are you also using the TempGraph plugin by chance?


#4

It appears this is an error caused by the OpenGL library. It displays fine on my laptop running Windows 7. It does not display the graphic on my desktop computer, also running Windows 7. My graphics card is an NVidia GeForce 7900GS. It's running with the latest release of the video drivers. Both computers are running the latest version of Chrome browser.


#5

The only thing I can think thi try would be to uninstall the video card drivers and reinstall them after a reboot.


#6

Hi @benebrady !
Does other open gl software run on that PC without problem?

I'm almost afraid the 7900 GS can't support recent open gl versions.
Reffering to this list, this GPU is just up to version 2.1. Most recent one is V 4.4


#7

I've done that several times.


#8

I'm trying to locate testing software right now


#9

Yes, other OpenGL software does run fine.


#10

It appears this might be sure to the version of open gl. My video card driver reports version 2.12.


#11

I see.
I think @jneilliii should know the minimal version of Open GL that this plugin needs.


#12

I wish I did. Unfortunately, I'm just embedding another library to do the work. I've searched and can't seem to find anything relative to this error.

@benebrady does the page linked below load for you? I don't think it will help, but you could try in Firefox.


#13

No that page only displays the grid and legend, just like the plugin. I didn't get an error, but also didn't get a plot.


#14

I don't believe it's related to the browser. I think it's more toward the graphics driver and the version of OpenGL it supports.


#15

I believe so since the plotly page doesn't load either. There's an error but probably only shows in the developer console. I'd bet it's the same error.


#16

I guess I'll have to buy a new video card to use the plug in with my desktop computer.


#17

Just thought you might like to know my issue is resolved. I have upgraded my video card to a new model that supports a newer version of OpenGL.
Everything is working much better.


#18

I'm glad that worked. If it didn't I was not going to have any idea on how to resolve the problem. Thanks for reporting back. Don't forget to mark your post above as the solution.