Bed Visualizer wont create mesh

I'm trying to use bed visualizer and have entered this G-code. I'm using an Ender 3 with a BLTouch and the skr mini E3 V1.2 board.

Hello @3DEnvoy!

When you Enter G29 T in the terminal, does the printer perform the mesh probing and is a report given after that?

The printer will perform the probing, but no report is given.

The T parameter should produce the report.
The G29 command is quite complex ( also depending on the Marlin version. Maybe changing the parameter gives a proper result.

It is very firmware dependent. If your firmware doesn't report the mesh at the end of the leveling process then there is nothing that the plugin can do to make it work. More than likely you'll have to increase the timeout value in any case if your not using UBL and EEPROM stored meshes.

Im new to the whole firmware thing. What should I be looking for in my firmware to get it to report the bed mesh?

Are you building your own firmware? There are lots of videos out there on YouTube and forum posts in other forums relative to that process. If you are building firmware then as long as you have some form of bed leveling enabled in that latest Marlin versions I think by default the reporting is included. It's just a matter of knowing what firmware you are building, and figuring out the gcode commands necessary for showing the report.

Not exactly building my own, I just flashed Marlin with BLtouch enabled, but I will take a look to make sure everything checks out. If the firmware is okay, are the G-code commands I have in the plugin the correct ones?

It should, again as long as it's based on one of the newer Marlin variants. I can't say for TH3D firmware or the like what is stripped out from the base Marlin branch. Those custom firmware providers sometimes strip out features to save on space. If you go to your Terminal tab in OctoPrint and type the command G29 T what happens, and what is returned in the Terminal tab as Recv lines (copy/paste them here)?

So I ran G29T (does it matter I didnt put a space?) and here is what I got after the probing was complete.

Recv: Bilinear Leveling Grid:
Recv: 0 1 2 3 4
Recv: 0 -0.475 -0.275 -0.035 +0.222 +0.455
Recv: 1 -0.208 -0.053 +0.147 +0.322 +0.505
Recv: 2 -0.005 +0.137 +0.355 +0.532 +0.727
Recv: 3 +0.237 +0.490 +0.572 +0.727 +0.872
Recv: 4 +0.415 +0.595 +0.785 +0.995 +1.195
Recv: X:176.00 Y:224.00 Z:13.62 E:0.00 Count X:14080 Y:17920 Z:5840
Recv: ok

Yeah, there should be a space, but the return should be graphing. Is your timeout value high enough for the probing to complete and spit out the above report?

Time out is set to 60 sec, and I do a 5X5 grid. Probably need to increase the timeout time

Yep, I bet that's the problem. The collection process is canceling before the probing process has time enough to complete.

I was hoping that was it, but I dont think so. I set the time out to 210 sec which allows the probing process to complete, but then afterwards no graph displays, it just gives me the option to update mesh again.

I dont know what I did, but I got it to work. I'm thinking I had another plugin that might have been interfering with the bed visualizer.

Thank you for all the help!

Hi, new to the forum so thanks in advance for any assistance. I am having the same problem where after completing the mesh probe it does not provide any visual map anymore. This happened after I updated the plugin to 0.1.12 from 0.1.11. I just went through the process of completely reinstalling OctiPrint and just the bed visualizer plugin and still nothing. I am running an Ender 3 pro with BL touch and the firmware is the Creality firmware for BLtouch. Any help would be greatly appreciated.

@trhessel, If you read through this entire thread you will notice that an exchange of information occured, like the results of commands executed on your printer. You might as well start by supplying the same information that was supplied by 3DEnvoy instead of waiting for us to request it, one piece at a time.

Thanks @b-morgan, that is correct, no details and I can't help. You may want to also read through this extensive issue on the repository. It seems that the biggest issue is not having a timeout large enough and making sure to restart OctoPrint after changing the value.

EDIT: Nevermind, I guess. I didn't realize that OctoPrint needed to be restarted if I make a configuration change in BLV. Now that I've done that, it seems to be fetching the mesh just fine.

Sorry about that!

Useless original detail below:

I recently updated my Ender 5 Plus to the Tiny Machines version of the Marlin 2.0 firmware, which is using Unified Bed Leveling (UBL). For some reason Bed Level Visualizer is not recognizing the mesh data produced by this update. Here's what I get when I update the mesh data in BLV:

Send: G29 T
Recv: Bed Topography Report:
Recv:     (  1,349)                              (349,349)
Recv:         0       1       2       3       4       5
Recv:  5 | -0.002  -0.002  +0.033  +0.010  -0.008  -0.008
Recv:    |
Recv:  4 | -0.002  -0.002  +0.016  +0.004  -0.008  -0.008
Recv:    |
Recv:  3 | +0.007  +0.003  -0.001 [-0.003] +0.002  +0.007
Recv:    |
Recv:  2 | -0.030  -0.030  -0.020  -0.024  -0.005  +0.015
Recv:    |
Recv:  1 | -0.020  -0.020  -0.008  -0.023  -0.020  -0.017
Recv:    |
Recv:  0 | -0.011  -0.011  +0.003  -0.022  -0.020  -0.018
Recv:         0       1       2       3       4       5
Recv:     (  1,  1)                              (349,  1)
Recv: ok P7 B3
Send: M420 T1 V
Recv: Bed Topography Report for CSV:
Recv: -0.002	-0.002	0.033	0.010	-0.008	-0.008
Recv: -0.002	-0.002	0.016	0.004	-0.008	-0.008
Recv: 0.007	0.003	-0.001	-0.003	0.002	0.007
Recv: -0.030	-0.030	-0.020	-0.024	-0.005	0.015
Recv: -0.020	-0.020	-0.008	-0.023	-0.020	-0.017
Recv: -0.011	-0.011	0.003	-0.022	-0.020	-0.018
Recv: Mesh is valid
Recv: Storage slot: 0
Recv: echo:Bed Leveling ON
Recv: echo:Fade Height OFF

The "human readable" format is produced by the G29 T; the more conventional format is from the M420 T1 V. The @BEDLEVELVISUALIZER tag directly precedes it in the GCODE commands configuration in BLV as seen below:

M155 S30
G29 T
M420 T1 V
M155 S3

I've tried a number of options for M420 Tn V, but none seem to help. Any thoughts?

1 Like

Yeah, I still haven't figured out what's causing that yet...