Brand New SD Card with latest version... Does not seem to have OCtopi

I have been using Octopi for several months with incredible ease... I decided to update to the latest version 0.17.0 by flashing the SDCard... but it seems like the application is not installed... What am I doing wrong?


We'd need details to answer this- your post gives a problem but nothing to possibly diagnose an answer. What does "the application is not installed" mean- you couldn't find an application to flash it, or the SD card appears empty, or the SD card won't boot in the Pi? That's just the first level of problem- keep going as you describe things, show a log of what happens, show screenshots, etc.

You are absolutely correct... My apologies. I flashed a brand new SDCard with the latest version. The Raspberry Pi does boot, but for some reason, when I go get the octopi-wpa-supplicant.txt is not there. Booted off the SDCard and setup the wifi manually yet I do not seem to find any trace of the Octoprint software in the SD Card...

Thank you very much. I did download it twice

@Wingman, You aren't grasping the "need details" requirement.

For example, replace "flashed" with "using balenaEtcher 1.5.79 on my Windows 10 desktop", replace "brand new" with "SanDisk Ultra Plus Class 10", replace "with the latest version" with " downloaded from , replace "The Raspberry Pi" with "Raspberry Pi 3B+", etc.

The more details you provide, the better chance we have of actually answering "What am I doing wrong?"

Without any details, our answer will probably be "Something".


Thank you @b-morgan
I have been using a raspberry pi 3B+ under the octopi-stretch-lite-0.16.0 version. Which ran flawlessly for several months. I decided to try and update the version to octopi-buster-lite-0.17.0 downloaded from the - Download & Setup OctoPrint website.

I flashed the 16Gb SanDisk MicroSD card with pifiller (MacOS Catalina 10.15.3) which I have used in dozens of my builds... including the Octoprint 0.16.0 version. Upon finishing the flash... I went into the boot folder from my computer and added a file named ssh to be able to ssh into the device... removed the SDCard and booted the Raspberry pi... connected to a screen... it booted directly to Raspbian and requested me to setup country, wifi, and updates...
once done.. rebooted. While reading some of the setup websites... it mentions the fact that the wifi is setup via a text file in the boot folder... (octopi-wpa-supplicant.txt) which is not showing in the folder. I looked around for anything that may resemble being part of the octoprint software and couldn't find anything... Unfortunately I flashed the original SDCard first... Then flashed a second SDCard with etcher on MacOS and I am getting the same results...

Thank you and I hope this makes it a bit more clear

I just used balenaEtcher 1.5.79 on my Windows 10 desktop to flash and there are two partitions on the flashed SD card. The boot partition contains octopi-wpa-supplicant.txt along with everything else I expect.

I then inserted the SD card into a Linux Mint 19.3 MATE system and both partitions were mounted. /home/pi was populated with all the usual OctoPrint stuff.

I guess the next step would be for you to verify that the image you downloaded is not corrupt. Underneath the Download button is an MD5sum. Hopefully you can find an MD5 utility for MacOS on your own because I can't help you with that.

1 Like

Thank you everyone... I am not sure what may have happened... But after downloading the zipped file for a third time ... flashed the same card once more with the newly downloaded img. and it finally worked like a charm. I am very confused of what may have caused the previous two downloads to be incomplete, yet still load a fully functional OS... I did installed Octoprint manually on the previous OS and it worked... but wanted to try it again after @b-morgan confirmed that the file was NOT corrupted... So I did... He was correct. Thank you for the assistance... I guess we will never know what happened...

1 Like