Camera Settings Plugin, Cannot get the controls to show after install

Good evening, Ladies & Gentlemen!

I am hoping someone can help me out here. I am running the latest version of Octoprint, along with the latest version of the Camera Settings Plugin. Octoprint and all the plugs I have installed work, except for the camera settings one. I can see my camera feed, I can use octoprint and all features, except for the camera settings plugin. After I installed the plugin, I rebooted the entire system and when I choose camera settings, I see the video feed. Below the feed where all of the setting sliders should be, is just blank. then below that, is the presets section and Multicam section, which I can see.

** What I have tried (in this order)

  • un-installing/cleanup of the camera settings plugin.
  • Running commands to install v4l-utils. (sudo apt-get update, sudo apt-get install v4l-utils)
  • Reboot entire system
  • Re-installed camera settings plugin.
  • Reboot entire system (not just restarted octoprint server)

and then try the camera settings again and still nothing.

I am hoping someone can help! Thank You in advance!

  • Chad

Hi there, I'm the author of the camera settings plugin.

Debug logs would be the most helpful thing to have here. Go logging in the octoprint settings, add a DEBUG entry for the plugin:

Then save and close the settings window. Then, open the settings and go to Camera Settings again, then back to logging and grab the octoprint.log and upload it here. After that you can remove the debug entry.

Other than that, a couple of quick things I can think of:

  • Is the camera connected to the same physical device that OctoPrint is running on?
  • If so, is the camera listed in the drop down next to the preview image?

@TTalkington HI!

Wow, talk about great support, this is possibly THE BEST support, I have ever received!

Okay so, I just did exactly what you said.. and when I downloaded the LOGS file, it was a . ZIP file, which is fine but, when I try to extract the file because I was curious what the logs looked like, it says sorry the file is empty.. you must add files to the compressed folder first.. So not sure why it's not adding any debug info when I add camera settings in the drop-down menu to be debugged.

As far as your questions, "other than that"..

  • Is the camera connected to the same physical device that OctoPrint is running on?
    • yes the camera is connected to the same physical device that OctoPrint is running on. There are 4 USB ports on my server. I am only using 2 USB's. 1 is going to my printer and 1 is going to my camera.
  • If so, is the camera listed in the drop-down next to the preview image?
    • The camera is not listed in the drop-down menu, next to the preview but, I can see the preview fine. I can, and have made time-lapse with the plugin, 'octolapse'.

When I make time lapse with that plugin, I noticed things I would like to change (settings) which is when I found your amzing plugin! I jsut cannot get it to work.

PS: I just started a print, and I created a link to share so people can watch it. Just figured I would post it to Facebook for whoever to check it out, so here it is so you can check it out and see that it works. (see that the cam works)

I have to run a few errands but, would love to chat afterward with you. I am not using the regular raspberry pi setup. Its a small mini computer about the same size but, yeah. Either way, thank you for the help so far! I am confident with your help, we can get it up and running!

Respectfully and VERY Grateful for your help,
Chad Winter

It sounds like you aren't downloading the proper log file. Even without debug info turned on the log file won't ever be empty.

If you click the link that's shown on the word logs, it takes to you a post with more details on another way to access them and where they are at.

At this point it's sounding like you either don't have the v4l-utils package installed (which should have resulted in a popup warning) or your version of v4l2-ctl has a non-standard output. I need the logs to be able to tell more :slight_smile: .

@TTalkington ! Hey buddy, I was able to do it and open it. I am uploading now. I did check the log and I see some errors when I try to open the camera settings plugin. I am sure you will be able to tell MUCH better than I. Thank you so much for looking at this, please let me know your thoughts. I will reply instantly, I really want to get this working! Thanks again!!! :grinning: (108.4 KB)

@TTalkington I did a little troubleshooting and I found the issue. I just dont know how to fix it..

When I try to run the plugin, the last command that is issued, which causes the error, is when it ask for the video. It ask for video1 but, i guess there isnt one. So what i did was run the command myself and got the same thing, NOTHING.

So, I changed the 1 to a 0, and i then get the control menus... I just dont know where I need to change my camera settings to make it video1 and not video0..

The command that returns nothing (the command that is issued when i try to use the camera settings plugin) is...
v4l2-ctl -d /dev/video1 --list-ctrls-menus

the command that list the menu controls is..
v4l2-ctl -d /dev/video0 --list-ctrls-menus

This still doesn't have the debug info enabled in it, unfortunately. I can see the error that you mentioned, but that's not actually indicative of a problem. Many USB cameras present as multiple /dev/video* devices and the plugin enumerates them all and parses through the output to figure out which ones look like they are cameras or not. Unfortunately, I can't just assume /dev/video0 is always the camera.

In addition to the debug output, what does the output of ls -l /sys/class/video4linux/ show?

so sorry, here they are. this one has debug enabled.octoprint-logs (1).zip (58.3 KB)

I have a hunch. I have no idea why this would be happening, but this should fix it if I'm right.

Please try this branch by going to the OctoPrint settings, plugin manager, 'Get More' and then paste this into the URL box and then install next to it:

I've also pushed my potential fix for this to the latest pre-release version (0.3.2rc1). You can update to that by selecting the 'Release Candidate' channel for this plugin in OctoPrint's Software Update settings.