Cannot access Octoprint from browser window

#1

What is the problem? Noob here sorry for my lack of tech knowledge..

I set up my Raspberry pi 3 b with octoprint yesterday and was able to access my printer fine with the ip address Pi provided at the end of boot up (pi) screen.. just imputed it into browser and all was well..

today it no longer gives me a standard ip. but but does provide http:2607:fea8:..... etc etc.. and three diff addresses it says will work on your local network ... on any open web browser..

when I input these addresses to a browser they do not work.. I tried all options on help page without success..

My local router admin page sees Octoprint pi however it gives MAC adresses and not a standard IP.. Angry scanner cannot find any ip's for octo

I'm using the latest version of Octoprint

ANy help ? suggestions?

Thanks!

#2

Hi @tt_now_now,

may I assume, you already restarted the RasPi and/or your router?

#3

Thanks for responding Ewald.. Yes I have restarted both

#4

Hmmm. A bit strange, that the router sees the Pi but do not provide a IP address.
Have you tried to give the Pi a static IP address?

#5

No I have not tried a static IP . do you have a link to a tutorial? tx

#6

What router do you have?

#7

So octopi sets to a IPV6 adress instead, do you have that enabled in your router and router dhcp server?

#8

I have a Hitron CODA-4582

#9
#10

I don't see a setting for that .. Maybe I'm blind.

#11

IPv6 Inbound Firewall
Firewall ENABLED
ICMPv6 Inbound to Hosts ALLOW
IPv6 Inbound Firewall Rules

and it does allow me to add a rule..

#12

As a test turn off IPV6 support in the router and reboot the octopi? Just to see what happens?

1 Like
#13

Thanks for suggestion.. does not work either way.. I was so excited when it worked the first day I ordered another RassPi for my second printer.. Only to discover I now have two rapPi and not octopi. ;-(

#14

I got an octopi.local to work.. and it is asking me for a user name and password.. nothing works.
it's not the default pi and it is not what I registed on octo web site.. what is it??? then when I check your web site to reset password the commands require a ~ sign which only works on a keyboard with my windows and using windows.. it does not recognize this symbol while typing within the pi.. You can't make this up if you tried.. lol. someone pls help..

#15

to clarify this is a browser user name and password.. no idea what that is or how to reset it. instructions to reset require command lines with the ~ which is to the left of the 1 on my keyboard.. but keying it with a keyboard on the pi gives me another symbol.. I don't even know if that is resetting the browser password..

#16

I see in the comments you do it through putty. I did that and I'm back where I started.. don't know user name and password when I open the IP in a browser.

#17

So to clarify ... I know my Raspberry Pi User and Password.. I just need the password that it askes when I input the IP address to a browser and it asks for a user name and password again.. tx

#18
  • When you remote into the Raspberry (with ssh or PuTTY), the username/password that you'd use is pi with raspberry (unless you changed that using sudo raspi-config but you likely did not).
  • During the Setup Wizard, the second screen asks if you want to use User Access control. If you indicated yes and added a user/password then when you visit the http://octopi.local web interface that is what it's looking for. If you can't remember what combination you entered before, then you could follow the instructions here to reset it to something else.
  • If you're having difficulty turning "octopi.local" into a useful IP address within your browser, you might read this if you have Windows for your workstation.
  • If you try to use IPv6—style IP addresses, don't forget that you have to surround them with square brackets. http://[IPv6-style-IP-address]/ as in http://[1234:5679:9012:3456]/
#19

OutsourcedGuru! You are awesome!!

1 Like