Cannot connect Pi4 to Prusa i3 MK3S via serial port on GPIO

EDIT: Was a bad board. Swapped in a new rPi4 and it works.

What is the problem?
I can connect no problem via USB, however I want to connect my Raspberry Pi 4 2GB to my Prusa MK3S via the serial port on the GPIO (similar to their Pi Zero W install).

I believe the issue is with a Pi3 you are supposed to edit the /boot/config.txt file and add
dtoverlay=pi3-miniuart-bt to the end.
That may no longer be supported by the Pi4. Anyone know what the updated code would be?

(see Step 10).

What did you already try to solve it?
Followed the instructions here

and here

Tried using Auto for Serial and Baud rate.

Also followed the article on increasing timeouts, etc (can't find article right now).

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!) (891 Bytes)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
Recently updated everything.
Raspberry Pi 4 2GB (latest FW, connected to 5V buck converter for power, large heat sink and fans)
Prusa i3 MK3S
OctoPi 0.17.0
OctoPrint 1.4.0

1 Like

after you add the overlay and reboot, you need to go into raspi-config and go to interfacing. click serial, tell it no console and enable hardware. Reboot then do a "ls -al /dev | grep AMA
you should see /dev/serial0 or /dev/serial1 linked to /dev/ttyAMA0 that will be the port you use

Mine is showing serial0 -> ttyAMA0
So do I delete the '/dev/ part on my Ocoprint connection Serial Port since it is not showing up as that when I did the ls -al /dev | grep AMA?

When I add /dev/ttyAMA0 and try to connect via Auto I get the a might not be a printer or just not allow programming mode error in the Terminal.

Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: ['/dev/ttyAMA0', u'/dev/ttyS0']
Trying /dev/ttyAMA0
Could not connect to or enter programming mode on /dev/ttyAMA0, might not be a printer or just not allow programming mode
Trying /dev/ttyS0

Also when it tries /dev/ttyS0, it just hangs trying to connect and no other commands or responses show up in terminal. I have to use Octoprint to reboot in order to recover.

No, you still have to keep it as /dev/ttyAMA0 since it is in the /dev directory

OK. Still have same initial issue. Still not connecting to printer via Serial on GPIO.

UPDATE: I tried with a Pi3B+ board, starting from scratch doing the exact same thing I did for the Pi4 board and was able to get the Pi3 board to work via serial GPIO to the Einsy board. I moved that SD card over to the pi4 board and still the same issue, pi4 will not connect. :frowning:

Any suggestions what to try next?

Go to the Raspberry Pi forums?

Turns out the board was bad. I swapped it out with another rPi4 and it worked.

1 Like

Great you found the solution!
Could you please: PSA: Please mark the solutions to your topics as such
Thank you!