Cannot Connect to https://octopi.local

Hi everyone, I'm still very much the newbie and I now cannot connect to Octoprint on my Pi 4. This happened after a test print yesterday that produced a satisfactory print. I now get "Connection Refused" in response to ssh pi@octopi.local; to make matters worse, it seems I've also lost the password for my Pi.

In the past I was able to connect to octopi.local from both my MBP (current Mac OS) and my iPad (current iPadOS).

In trying to isolate the problem, I established that

  1. The Pi has an IP address - according to my router.
  2. I can ping the Pi at the reported IP address
  3. I cannot use a browser to connect to https://octopi.local - browser reports it cannot find the server at that address
  4. I can't get into the Pi using ssh pi@octopi.local; that produces the Connection refused message, and identifies the port as 22.

The Pi is dedicated to Octoprint, no data on it that I care about, so I decided to try fixing both the connection and password problem by re-imaging it. I downloaded the latest Octopi zip file (today), created a new MicroSD boot drive, and edited it according to the information at - Download & Setup OctoPrint (used Balene Etcher to place the image onto the MicroSD)

I inserted the new MicroSD card into the Pi, powered up and observed the Pi reading the SD card.

My current situation is

  1. Pi boots and gets an IP address (according to my router)
  2. I can ping Pi at reported IP address from terminal.
  3. When I use terminal to ssh into the Pi, I get the same Connection refused message.

I searched the forum, noted some posts about ssh known_hosts, but that information did not help (perhaps I don't know Mac OS well enough).

It seems that trying to solve my problem by re-imaging the Pi has not made any difference at all. I'd appreciate any suggestions as to next step, please.

I am really surprised, because I printed successfully late yesterday, and when I tried to send the next test to the Pi (from my MBP) a few hours later, I could not access https://Octopi.local or the Pi itself. Something must have changed, but I don't have any clues.


Ok, problem solved, but I have to explain my ignorance.

I was putting my new MicroSD card in the wrong slot on the Pi. When I put it in the correct slot, I got into the Pi from terminal.

Sorry, just imagine how sheepish I feel right now. And I don't mind if you laugh, just be loud.


Congrats. I doubt that anyone would have said "first check that you have the sd card in the correct place" :slight_smile:


Wait a minute: AFAIK there is only one SD card slot on the Pi.

So you found the issue, could you please:

Ewald, you are correct, there's only 1 MicroSD slot. But I have my Pi standing on that side of its case, on the opposite side there are 4 USB slots that seemed like the obvious target for my MicroSD card in a handy little adapter that enables me to put the card in any USB slot (here The Pi/Octoprint have been working so well I had completely forgotten about the actual MicroSD slot; out of sight, out of mind I guess.

I still don't have any idea what caused the Pi to misbehave, and I was even more puzzled that my efforts to change things had no effect.