Cannot get plugins to load on OctoPrint v1.3.12, OctoPi v0.17.0 on Raspberry Pi 4B 2GB V1.1

What is the problem?
I am getting

Could not parse output from pip, see plugin_pluginmanager_console.log for generated output

when loading plug ins on OctoPrint v1.3.12, OctoPi v0.17.0 on Raspberry Pi 4B 2GB V1.1

What did you already try to solve it?
I have also tried to install plug ins using the URL installer with same results and error following the "Installing a Plugin" help page. I did not try manual install as I am fairly new and not sure how to do a manual install.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Logs attached

If you need more logs please let me know.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
OctoPrint version = v1.3.12
OctoPi version = v0.17.0
Raspberry Pi 4B 2Gb V1.1
Printer = Creality CR-10S w/BLTouch mod
octoprint.log (177.0 KB) plugin_pluginmanager_console (2).log (19.6 KB) serial.log (148 Bytes)

Based on the logs the device cannot either:
A) Resolve DNS
B) Get out to the internet

Question from my side:

  1. How would I be able to see the plugin library if not connected to the internet?
  2. The DNS...I had some issues with connecting tot he internet and one solution was to change the DNS to from which I did. After this change I was able to see the Plugin Library..prior to that I got the "Sorry your not connected tot he internet" from the plugin library.

If I log into the Pi directly I can ping and see a return so it is connected to the internet.

Can you resolve DNS though?

Can you pull down the website?
curl ""

Caching from a time when you Pi was still able to resolve hostnames correctly. Looking at your log, it currently isn't, there are name resolution errors littered all over the place.

I get -bash: dig: command not found

curl ""
I get curl: (6) could not resolve host:

I did this though logging into the Pi from PuTTy. Sorry I am new to the programming side.

I have the pi hooked to the internet through WiFi. I ran scan from the Pi and i am seeing the network. Getting quality 52/70 with a signal level- -58dBm

curl confirms the problem. DNS are not valid or are unreachable.

Take a look at WiFi setup and troubleshooting

If the device is definitely connecting to WiFi properly then check your router/dhcp server to ensure the right DNS IPs are being handed out.

OK I have gone through the WiFi Setup and troubleshooting.
Maybe I am missing something in this page....

When i check the WiFi Sudo iwlist wlan0 scan i can see the wfii

Hopefully this jpeg is not giving away any personal info.....

If I ping


If I ping

I tried curl "https//" again and now I get this.....

After being able to have the curl work....I tried to load a plug in...failed with same error

Here is the log

plugin_pluginmanager_console.log (22.2 KB)

Right after using the curl and getting th website code....
I tried dig


Then curl again

I wonder if there's a PiHole somewhere that's nomming your pip install.

OK...I'm new so...what's a PiHole?

A PiHole is usually a Raspberry Pi on your network that you've created to swallow advertisements. It's known to also swallow pip's attempts to fetch installations and updates.

But since you don't know what this is then ignore.

I have a couple DNS servers on my local...could they be affecting this?

OK....So OutsourcedGuru made the comment about a PiHole......I have a couple DNS servers on my home network.....well a listing of them on the router for DNS. Both servers are not running as the computers that they are associated with are down. I took the reference of the servers out of the router and.....PlugIn installs and I now have a notification of OctoPrint 1.4.0 being available.

OK folks......
Not sure the what/how or why on this issue from the software side BUT on my router I have 2 DNS servers set up. Both happen to not be on the network anymore. I removed the DNS reservations from the router and that solved MY particular issue.

DNS strikes again! :upside_down_face: