Cannot install any plugin after fresh octoprint install

Hello everyone !

So I have been stucked with some days now. I can see that I have the same problem of some other users but I couldn't find a topic with the answer to my issue.

I installed octoprint on my raspberry pi 3B+ and i am having issue to install any plugin from the plugin manager.
What I want to do : Install any 3rd party software (tried with octolapse & bed level visualizer so far)

What's wrong : from the plugin manaer, I have a error message at the step: "building wheel for numpy ( started "

It looks like it may be an issue with pillow because the plugin manager has been stucked several time at the step "collecting pillow" and then it stopped doing anything and the server got disconnected.

I tried to connect via SSL and do the following :
source oprint/bin/activate
pip install --upgrade pip --> worked until here
pip install pillow --no-cache-dir --> didn't work and the server stopped responding.

I did'nt do anything with my raspberry and octoprint so I think my set-up is still clean and I don't know what causes this issue or how to resolve it.

I would be really glad if you could advise me on what to do next so I can finally uses octoprint to its full potential with the plugins :slight_smile:

Thanks in advance

plugin_pluginmanager_console (1).log (61.1 KB)

Does your network block

2020-03-31 19:27:43,824 ! ReadTimeoutError: HTTPSConnectionPool(host='', port=443): Read timed out.

You can ssh in and try curling it:

curl -D - -o /dev/null

Paste the output in this thread. And for further help you'll need to properly upload your octoprint.log.

I just uploaded my plugin manager log and will update my octoprint log as well now !

I will try your suggestion and send you the output ! Thanks

octoprint.log (225.8 KB)

Hi there !
Here here the output of your proposed instruction:

pi@octopi:~ $ curl -D - -o /dev/null
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0HT TP/1.1 301 Moved Permanently
Date: Tue, 31 Mar 2020 18:07:04 GMT
Content-Length: 0
Content-Security-Policy: default-src 'none'; style-src 'unsafe-inline'; sandbox
Strict-Transport-Security: max-age=31536000
Vary: Authorization,Accept-Encoding
X-Content-Type-Options: nosniff
X-Frame-Options: deny
X-XSS-Protection: 1; mode=block
X-Varnish: 374638208
Age: 0
Via: 1.1 varnish (Varnish/6.0)
X-Cache: MISS
X-Cache-Hits: 0
X-GitHub-Request-Id: CA04:0205:2AEC:5708:5E8386C8

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

I have to say that I don't know how to interpret this output

That's fine. It looks okay. It doesn't have the same error your plugin log showed. It looks like things may be working, it's just at a very slow step, this is what the plugin manager console last showed:

2020-03-31 20:13:20,564 > Building wheel for numpy ( started

Unfortunately you restarted your Pi (or octoprint) at least 3 times after that. I suggest starting the plugin install and leaving it alone for an hour. If that doesn't work, start from a fresh install again.

I have been waiting during the plugin installation but it got itself disconnected (I've got the message from the UI "server disconnected").
It may be an issue related with the response time ?

Preinstalling numpy is the way to go here. Don't worry about the web interface and open an SSH connection to your pi and run these commands.

cd ~/oprint/bin
./pip install numpy

Let it run until it's done, it will take a long time.

1 Like

thanks ! i will try it right now :wink: I'll let you know if it solve my problem

= "30 minutes"

i've been stuck on it since 1 hour and nothing seems to happen :confused:
is it supposed to do something ?

it seems that i keep getting this server disconnection after some time when nothing's happen.

I forgot add the no-cache-dir flag to that install command. If your download was corrupted I guess it could be causing an issue. Try these commands.

cd ~/oprint/bin
./pip install --no-cache-dir numpy

And if you're curious about the progress, feel free to bring up a second remote session to the Pi, run htop, sort by processor time and watch that run. (I usually do a sudo service octoprint stop if I'm manually installing things like this to free up a little core.)

Ok so i tried on emore time to install numpy using your additionnal instruction, and I've got a crash only a few minutes after it start.
At least it displayed some warnings this time.

May it be related to a wrong folder architecture that could have been caused when i first tried to install plugins via the UI ?

2020-03-31 18:49:06,371 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

This is from your log. Your Pi is not getting enough power to run reliably. This is most likely why things are breaking when it gets under load (e.g. while building numpy).

Get a proper power supply for your Pi.

you're right that i am using a 1 AMP power supply and I wanted to change for a new one but a cannot go shopping for now !

I though that 1 AMP may be enough if it was only to power only the board without any device on it but apparently it may not be the case

I will manage to get a proper 3 AMP PSU

Building numpy is a great stress test for that :slight_smile:

1 Like

Hi everyone, just to close this topic, I could get a proper power supply and in fact it was the problem..
thaks everyone for your time and help !