Cannot install Plugins

I cannot install Plugins. Octoprint only seems to work with Python 2.7 but Plugins ask for installing >= 3.5

RuntimeError: Python version >= 3.5 required.

which plugins are you trying to install?

The one mentioned on this Website: http://3dprintbrothers.xyz/2018/12/21/das-problem-mit-dem-krummen-druckbett/

It is available at this link https://github.com/PrusaOwners/OctoPrint-PrusaMeshMap/archive/master.zip

Is there any way to install Python 3.8.0?

Hi @MortalWombat,
IMHO it has nothing to do with the python-version. Btw. most Plugins of OctoPrint use 2.7 and not compatible with python3.

The problem with you mentioned plugin are the dependencies. It used several packages:

# Any additional requirements besides OctoPrint should be listed here
plugin_requires = ["matplotlib>=2.2.0", "numpy", "pyparsing", "cycler"]

And take a look into the Homepage of the plugin (see Raspberry Pi Users):


Please do the hints on the homepage. If you still have problems, please attach the octoprint log-file.

BR
Olli

1 Like

Update: okay, forget about that. Bed Level Visualisation returned an error message but worked anyway after rebooting.

Ok, I will check the homepage. Still... I did not manage to install any Plugins. I also tried Bed Level Visualisation within the Plugin-Manager. It took 2 hours and then it reports an error. Pretty frustrating...

Update: Thanks a lot Olli... it worked. I found it difficult if you have never worked with Terminal/UNIX before, but in the end it can be done. Even by noobs... :smiley:


Ok cool... I´ve never seen the homepage since I always tried to follow the guide on that other homepage. Now that I'm installing it manually in the terminal, it seems to work. I'll let you know later. Thanks for your efforts.