Cannot see VIRTUAL printer on connections


#1

I am trying to setup a virtual printer, but I am not be able to see it, despite of I followed the steps described here: http://docs.octoprint.org/en/master/development/virtual_printer.html#enabling-the-virtual-printer

My settings and environment are:

OctoPrint 1.3.10
|  hardware:
|    cores: 8
|    freq: 2900
|    ram: 17179869184
|  os:
|    id: macos
|    platform: darwin
|  python:
|    pip: 19.0.3
|    version: 2.7.15
|    virtualenv: /Users/sahelanthropus/OctoPrint/venv/bin/..

My yaml.config I set is:

devel:
  virtualPrinter:
  enabled: true

After restart OctoPrint it becomes:

devel:
  enabled: true
  virtualPrinter: null

On localhost:5000 is see:

51

Where am I wrong? Is it a bug or is it my fault?


#2

Omg. I solved rewriting the YAML configuration file as follows:

devel:
  virtualPrinter:
      enabled: true

now it works.

:see_no_evil:

I prefer to leave the question, however trivial it may be, because it might help someone else.


#3

yes its YAML XD
20 Zeichen ...


#4

I can highly recommend to read through http://docs.octoprint.org/en/master/configuration/yaml.html :wink: