Can't connect to Octoprint after installing plugin


After installing the plugin for the Creality fix for 2X temperature reporting, I can't log into Octoprint from a browser. It boots and looks good but when I try to login I get the following message:

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log , there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart .

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

How do I go remove a plugin?

Have you already done the things that are suggested in that error message?

My problem is that the | key on my keyboard shows up as the ~, I've pressed every key on the keyboard and the | doesn't come up.
Having said that, I have looked at the octoprint.log, best I can figure is that python isn't starting, not sure how a plugin would cause python to crash though.

Post the OctoPrint.log (you can download something like Windows SCP to get the file) here and we'll figure out why.

Here's my octoprint.log file, if you look at around 13:30 yesterday, I believe that is when things started to fail. Tnx
octoprint.log (148.3 KB)

Is there a file in /home/pi/.octoprint/plugins? If so, could you try moving it out of that folder?

That worked! I moved the 2 files out of there and I can connect. Were they supposed to be removed when I installed the plugin?

Thanks for your help.

when you log in locally, you need to run sudo raspi-config, go to localization and select the proper keyboard, then | will show as |

1 Like

That's where single file plugins are supposed to go, which are currently only really used for hot fixing communication or bugs. Maybe you tried to install something that it thought was a single file plugin, but was actually not.

I suspect that my original version which was a single file was manually installed in the past. That code was then turned into a full plugin. If the manually installed version and the plugin were both active, I can understand why there were issues but I glad to see they have been resolved.