Can't SSH even though password is correct

I am setting up octoprint on a raspberry pi 3 b+ and I can't SSH into the server. I keep entering the default password and it keeps saying "Permission denied (publickey,password)" I know I'm entering the password correctly.

I tried changing the password in the imager but it doesn't work.

Hello @kennyjb !

To verify, you use:

login : pi
password : raspberry

If you are using a non English keyboard, some letters have different position.

I am using an English keyboard and it's not working. I use the raspberry password and it just says "permission denied, please try again". The other weird thing is that it's not even asking for the username. I've done this a while back and I believe it asked for it then.

How are you trying to SSH - what software/command? By default windows tries to use the same username for your PC to access the Pi, which obviously doesn't work. You have to make sure to specify ssh pi@<the IP> to make that work.

This worked, thanks a lot

1 Like