Change Filament command (M600) doesn't resume printing if Telegram Plugin is installed

What is the problem?

I was experimenting with multi-filament prints, so in Cura I added a "Filament Change" script that sends a M600 command to the printer. When I used the printer's button to tell the printer to load, purge and resume printing, the print head moved into position but it just didn't move. The nozzle just sat touching the previous layer.

What did you already try to solve it?

First I ran a test print in safe mode and it worked fine. Then I rebooted in normal mode and disabled all my plugins and tried again. Then I started enabling plugins one by one and doing test prints until I found that the Telegram Plugin caused the issue.

I also tried enabling just the Telegram plugin and disabling every 3rd party plugin and that also causes that issue.

In Telegram, the bot that talks to me only warns me that ":warning: Color change requested." and ":warning: User interaction is required", but there's no prompt to resume the print. It's just a warning message.

Looking at the github repo, the plugin seems abandoned and there are A LOT of open issues. So yeah I don't think this plugin is safe anymore.

Have you tried running in safe mode?

Yes. It works in safe mode.

Did running in safe mode solve the problem?

Yup!

Systeminfo Bundle

octoprint-systeminfo-20220717204837.zip (157.1 KB)
plugin_list.zip (1.1 KB)

Additional information about your setup

  • Python 3.7.3
  • OctoPrint 1.8.1
  • OctoPi 0.17.0
  • Marlin 2.0.7.1

Thanks for letting us know :slight_smile:

Curious if it does the same if you use the command @PAUSE instead of M600?

The Filament Change post processing script doesn't allow for a @Pause command, but Pause at height does. I'll try what happens if I use this script, it may serve as a workaround.

I think that in combination with More nifty pause and resume would be close to the same thing, if it works on your printer.