Communication error Wanhao I3 Pi3

Don't confuse /boot/config.txt with /boot/cmdline.txt. The latter is a single line. The former is many lines.


Ye sorry, that's just a mix up in the reply, I edited cmdline.txt and not config.txt

One line, not two. It's not going to read it like that.

Thanks, i'm in the middle of a print ATM, will try it again later, I've rerouted my USB cable too, just in case there is any interference, despite it being shielded and working with other cables too and added a noise filter ring clip thing.

Near 1 hour 30 into a print with no disconnect yet.

Will report back.

This could be the fix, actually.

Any reason why all of a sudden it would play up?

PSU failing maybe, outputting more noise than usual?

Everything else seems fine though, nearing the end of the print now, gonna leave it idle overnight and see if it's still connected in the morning,

Once upon a time when the Earth was cooling and the dinosaurs ruled the land, I worked in the Pentagon in a crypto shop. I was amazed at how easily electronic signals of all kinds could be induced from one circuit to another. In the Cold War, we were mostly worried that the not-yet-encrypted signals would somehow be seen on something else.

Why could electronic noise be felt on your serial cable? It could be anything. It's usually those little rectangular driver circuits you find on your Ramps or similar board which are to blame. Anything which sparks/arcs is another prime suspect for electronic noise. Anything metallic like an antenna which feels a signal can broadcast that signal (and a wire is an antenna if you think about it).

High-frequency electronic noises can be squashed inductively (ferrite core). Low-frequency electronic noises can be squashed capacitively (capacitor coupled). Where it gets interesting is that an air gap between the male/female contacts of your USB cable are in fact a capacitor, if you think about it. So make sure that each connection is snug (doesn't wiggle around).

Still the same, it made it through a 3 hour print plus about another hour idle, then dropped out.

Edited the cmdline.txt again and my sd card got corrupt, so I've started a fresh on 0.16 instead of 0.15 and upgrading to 0.16

Hoping maybe from upgrading from 0.15 to 0.16 in the past didn't do it's job properly and this fresh install will solve the issue.

I live in hope :stuck_out_tongue:

Alright, well good luck.

So, more tests done, tried with the cmdline.txt like this

dwc_otg.lpm_enable=0 dwc_otg.speed=1 console=serial0,115200 console=tty1 root=PARTUUID=d2a7198d-02 rootfstype=$

all one line, dropped out still, that's with the fresh install the ferrite clip and shielded usb cable

How can I tell if the connection has gone back to 1.0/1.1 speeds, tried a lot of different commands but none state the speed.

Got a new FT232R today, last resort is swapping it over.

Maybe... sudo lsusb -vvv ...?

So I got round to replacing FT232R today, all changed over and it.........made no difference, disconnected within 5 minutes was able to reconnect the same as before, so i'm guessing my Pi3 is the cause of this now, I can't seem to get it to lower the USB speed down to 1.0 or 1.1.

Got another PI coming in a few days, just to rule out the PI itself, I have had one or 2 issues with it in it's lifetime, not booting after a new card is inserted, having to reinsert the card and power back on, I'm doubting the PI is at fault as everything else seems to work.

I was reading a post about RF possibly interfering with the serial to usb, basically as @OutsourcedGuru mentioned earlier on, I should of maybe tried to move the printer to another room first, but there's nothing new been introduced into the room since it was fully working last year.

At a loss really now, going to give the new PI a go, move the printer and PI, then call it a day.

1 Like

It can be frustrating at times like this. I've been troubleshooting for about four decades now and I've seen some things that just leave you shaking your head by the end of it: did this little whatever really cause all this? I'm reminded of where the term "computer bug" originally came from. The Mark II computer filled a room and had lots of physical relays but the old-school type which didn't include plastic housings. They troubleshot a program problem down to find out that one of the relays had a moth stuck in it, preventing it from closing. So they debugged it, for the win.

Just a further update to this, last week I upgraded to marlin 2.0 hoping this would solve this issue, it did seem to at the time but only for a longer period of time.

I narrowed it down to a electrical appliance, the freezer in question on the same breaker or whatever it is, was causing a voltage dip when the motor kicked in, causing the printer to disconnect for some reason.

I've since moved the freezer onto another breaker in another part of the house and the disconnects have gone

While this exact scenario may not be applicable to everyone, I've seen a number of other users with melzi boards facing this exact issue with other electrical appliances

I'm hoping that someone may spot this with the same issue and save them the headache I went through

Again, this wasn't octoprint at fault, so my apologies for blaming it :slight_smile:

1 Like

Excellent. I often suggest that everyone put their 3D printers on a UPS (which would have fixed this without moving your freezer to another circuit).

Electrical trivia: house circuits usually come in (here in the states) as twice the 120VAC (240VAC) at the main circuit breaker box. So one (hot) leg goes on the left side of the box and the other (hot) leg goes on the right side of the box. There's then a middle ground bar. So by tapping left-to-center you get 120VAC, tapping right-to-center also gives 120VAC and tapping left-to-right yields a 240VAC circuit. The problem happens when a non-contractor starts adding circuits into the box and doesn't match the 120VAC load left versus right. And I've even seen many contractors who will just go by count of circuit breakers rather than combined load.

So many homes are "heavy on the left", for example. There will be too much load on the left set of circuit breakers versus the right set. Hopefully this makes sense.

So... when you suggest that you moved the freezer to another circuit, what's most likely is that you moved it left-to-right or right-to-left on the circuit breaker box. (You could have merely moved it to another circuit on that same side/leg and it wouldn't have fixed anything.)

1 Like

Ye that's basically it, UK wiring is different I believe but the analogy is the same.

I did look into a UPS but with the cost and bad reviews and battery failures down the line, it just didn't seem worth it

Thanks for all your help earlier in the tread too, I appreciate it

1 Like