Configuring DetailedProgress Plugin


#1

Hi,

can somebody explain me how the Plugin can be configured?

I already read the hint here

but i don't know which file has to be edited (and before or after installation)?!

Greetings from Germany,
Chris.


#2

Hi Chris!

Now as you say - can't find it too...
It should be included to the config.yaml, but it seems, there are problems too.


#3

On the Raspberry Pi, it should be here:

~/.octoprint/config.yaml

Since that period is in front of .octoprint, it's naturally a hidden directory under the pi user's home directory.


#4

Hi,

the hint to the config.yaml was the missing information.

After stopping the service I was able to edit it with PuTTY and now it works fine :smiley:

Thank you (both)!


#5

How, I have been trying for 3 weeks now? I am a NOOB to coding.....


#6
  1. Remote into the Raspberry Pi: ssh pi@octopi.local using "raspberry" as the default password for the pi user.
  2. Run the following command: nano ~/.octoprint/config.yaml

Scroll down until you find the section which has plugins:. Assuming that you've already installed detailedprogress, look for that subsection then edit it to look like the following:

plugins:
  detailedprogress:
    # Number of seconds (minimum) to rotate the messages
    time_to_change: 10
    eta_strftime: "%H:%M:%S Day %d"
    etl_format: "{hours:02d}:{minutes:02d}:{seconds:02d}"
    # Messages to display. Placeholders:
    # - completion : The % completed
    # - printTimeLeft : A string in the format "HH:MM:SS" with how long the print still has left
    # - ETA : The date and time formatted in "%H:%M:%S Day %d" that the print is estimated to be completed
    # - filepos: The current position in the file currently being printed
    messages:
      - "{completion:.2f}% complete"
      - "ETL: {printTimeLeft}"
      - "ETA: {ETA}"

Yaml files are picky about the format. Use two spaces for each indent. For the section that you'll be adding, most of that is four spaces or six space toward the end. This is important for OctoPrint to be happy.

  1. When you've finished your edits, Ctl-O (that's an "oh") to save it then Ctl-X to exit out.
  2. sudo reboot # ...providing that same "raspberry" password from before.
  3. After the Raspberry Pi reboots, then see if it works.

#7

No go...… :frowning:


I canot figure it out I am about to give up the ghost...…


#8

LOL reinstalling my image backup again.....


#9

Ok I have been able to get the % to show up, no more hanging up when the bed temp hits its set point, and I am printing. However I still ca not get the last number or letter to show up. When I added the above info you sent me some of it "disappeared" in the config.yaml., also I had to switch back to part of the old setup file to get it to where I am at now...….. Here are the screen shots and photos...… I really THANK YOU for all your help here!!!



#10

Post your config.yaml and we'll take a look at it.


#11

This is going by the post...…. time_to_change: 10 keeps disappearing...… and I get "Hung" on temp change from bed to hotend...… have to reboot...… the spacing will not stick...…. using notepad++ or nano……..


#12

I found this and tried it, this was how I got it to do something...… as in the screen shot pics of the LCD screen..... but with only one of the "%" signs....


#13

It looks like this is the pertinent part of your config.yaml.

By inspection, it looks like the percent sign is used to mark variables in some of these. For example, "%H" would likely expand as the HOUR of the day. So it's possible later when you are trying to actually print a percent sign, the command is confused. In many cases in programming, you're expected to "escape" these sorts of characters. (We might have to do "%%" or "\%" in order for that to behave.)

Why not try an exploratory attempt to see if this is the case?

  - '{completion:.2f}\% complete'

Note that I've inserted a backslash before the percent sign in this version.


#14

Well that was a no go.. back to where I started, it showed a weird symbel in the LCD and started the same stuff as I listed in piror post from Oct 5th...…. I am beginning to think it is a issue with my marlin firmware on the last placement of the letters and the date, Marlin ver is 1.1.0 on a TronXY X3A_8...….


#15

Or try it like this:

  - '{completion:.2f}% complete '

Note the extra space after complete. (In this case, the thought would be that something has miscalculated the string length by one character.)