CostEstimation plugin not computing cost


#1

I've installed Sven Lohrmann's CostEstimation plugin, as well as his Filament Manager plugin, and filled in all of the requested data (filament cost, electricity cost /KWH, etc.) but I'm not getting any cost info showing up in the browser (is says Cost: - but no price is shown). The companion part, the Filament Manager is correctly keeping track of how much of each filament type that I have, but either the two aren't talking to each other (yes the setting is set under CostEstimation for that to happen), or something else has gone wrong.

Has anyone else had this problem? Or conversely, is anyone using the two plugins in tandem and getting a cost to show up on the OctoPrint browser?


#2

Same issue with cost estimator a few weeks back. Decided to try the RC channel with the latest build and now both don't work.


#3

Both work here against 1.3.7rc4. Note that GCODE analysis has to have run through in order for both to be able to work (no info about the filament usage and runtime of the job, no cost estimate). At least in the screenshot up there it doesn't look like the analysis has actually run.

image


#4

Interesting. I definitely ran the GCODE analysis, as I was watching the CGODE Viewer screen during the print. I also notice that in your screen shot the Cost line is at the bottom of the second group in the State div (below Printed nn KB). while in mine it is located at the end of the first group (below Approx Total Print Time)

I am also running OctoPrint 1.3.7rc4, on OctoPi 0.14.0 with Cost Estimation 2.1.0 and Filament Manager 0.5.3


#5

The GCODE analysis is not the same as the GCODE viewer. Analysis is done Python side in the backend once. The GCODE viewer also has analysis built in, that's done on the client side though and every time you load the stuff into your browser.

The screen shot was from "Cost Plugin 0.1.3" on OctoPrint 1.3.7rc4 running on OctoPi 0.14, but I also tried Cost Estimation and also had a value output (same instance).


#6

Thanks Gina! I didn't understand the distinction between the two. Is there a way to tell when the backend analysis is complete? Perhaps an indicator of some sort on the web page? If so I can wait until I see that before starting a print.


#7

When "Approx. Total Print Time" and "Filament" are populated. Or alternatively when the little down arrow in the file list becomes enabled.


#8

I ran across this same problem when I used Octoprint install on top of existing rasbian image following the guide linked from the setup page. I wiped my rpi and loaded octopi to it instead and it all works.

In my logs, when I had Octoprint on top of rasbian I would see, some server gcode analysis kick off but never reported back it was complete. Also I think I saw inconsistency with it running the gcode analysis after file upload.

So, I am guessing that my manual install of octoprint had user problems, maybe the guide misses a step, or a permission issue.