Crealty Printer Disconnecting From Octoprint Randomly

I have an Ender 3 Max. It's in a Creality "fireproof" enclosure, it's my first printer which I've had for around 18 months & for most of that time it's had random stopping issues. The first random stops happened while it was still in warranty & printing from SD card. The shop I bought it through had a contact at Creality & who I had direct contact with via Whatsapp. They had me do every test known to man as well as provided me with new firmware, it made no difference so they condemned the main board (V4.2.2). They gave me a 4.2.7 which I installed & loaded the firmware they provided & all was well for a week or so. I learnt how to set up Marlin for myself, downloaded, set up & loaded the latest firmware, made no difference. I bought a Pi Zero 2W to try Octoprint. It made no difference, did some research where the Zero 2W was getting the blame. I'd bought a Pi4 to use for something else, tried it, it seemed to cure it. Then after a week or so it started happening again so went back to printing from SD card, same thing, so it's nothing to do with the Pi's, I knew that from previous experience. Back on the Pi4 I tried ferrite beads on all the wiring of the printer, the Pi power supply, the USB leads, the webcam all to no avail. I took the main board out & wrapped it in tin foil, no difference, I disconnected the printer control panel & cable, no difference. I had LED bulbs in the room ceiling lights, I measured the EMF which read over 700, changed them to incandescent bulbs, measured the EMF & it was virtually zero, no difference, if anything the printer is worse. Today it has stopped 4 times & that's while trying to print a 39 minute print. One time it disconnected from Octoprint the instant I switched the ceiling lights (incandescent) on. It's been running Marlin Bugfix since July.
So after all that it seems to me that the Creality main boards are highly susceptible to EMF & you get that when you switch things on or off, in other words the boards are crap.

I'm in 2 minds whether to try a different brand of main board or box the thing up, sell it & buy something else which is not Creality.
I have seen there are other threads with Creality printers having the same issue. Are there any other brands of printer with this problem? I haven't seen any on my Google travels