[Dashboard Plugin] Feedback needed

Yeah, for the software updater to see the change you have to make a release in github with the version as the tag version and release title, so if you are going to 1.0.0 use that in those two fields. That will allow the software updater to see the new version.

I just created the v1.0 release on github and issued a pull request to the plugin repository. Let's see how it goes :slight_smile:

Dashboard v1.0 is now available in a plugin repository close to you. Thanks for all the support and suggestions so far!

My todo-list for a future version includes:

  • Support for translations to other languages.
  • Support for temps in Fahrenheit
  • Custom temp ranges for the gauges
  • Layer progress gauge.

Guys. Firstly I'd like to thank you all for writing some fantastic codes to make people like me learn and appreciate what these printer & PI can actually do.

I've been printing about a year with my Ender 3 with many modifications......

I don't normally use forums as I've managed to work through all my issues but this one i'm stuck on

Dashboard looks fantastic - just not on mine
I can't get more than the basic fan & temp to work on Windows laptop or Raspberry PI (3+ b)
I've installed "displayLayer" & "PrintTimeGenius" as recommended
I've tried uploading new code from Cura 4.1 and PrusaSlicer

I'm sure it's something I've done but being pointed in the right direction would really help and appreciated

Ender 3 Pro
Marlin 1.1.9
Raspberry PI 3 B+
Raspian Buster Lite
OctoPrint 1.3.10


That looks like a data binding issue that I haven't seen before. Please post your issue on https://github.com/StefanCohen/OctoPrint-Dashboard/issues and I'll try to investigate further.

And make sure to indicate screen resolution and give an idea of how much screen space the browser is using. It looks like it's been shrunk down to me.

I agree, but all the viewmodels should still be there, right? In this case, it looks like the FanSpeed data binding failed. This could be an issue with my event hooks for displaylayerprogress.

Thanks Guys, have added to "Issue 14"
I realise the laptop is of low spec but the dashboard is the same on both

Raspberry PI 3B+
Raspian Buster Lite
Elecrow HDMI 5 inch 800*480 TFT (https://www.elecrow.com/wiki/index.php?title=HDMI_Interface_5_Inch_800x480_TFT_Display)

lenovo ideapad s130-11igm
Windows 10
Octoprint Ver 1.3.10
1366 x 768

Knowing this allows Stefan to adjust his own browser to that in order to see what happens with limited real estate.

Thanks, the PI is 800x480, the laptop is 1366x768 but only 11" screen
Pictures are original size from laptop

Stefan, Really appreciate you looking into this but I am now sorted.
I've formatted and started again with the "stretch" version (OctoPrint.org - Download & Setup OctoPrint)
Clean install, same plugins, same theme, etc and it just works.....

I'm guessing I have been playing with so many different screens / drivers I had caused a problem. I now have an additional 0.5GB space so there was a lot of unused rubbish on there.

I'm sorted and thank you for your time. Ian

@iancattermole Did you have Themeify installed before? If so, that might be pertinent. Otherwise, any plugin which throws a JavaScript error before the Dashboard plugin's JavaScript can prevent his code from binding.

Yes, everything the same. Only difference was a load of drivers, etc no longer required and moving back to stretch from buster lite


After todays update i cant see hotend temperature diagram. He have been disappeared. I tried to restart but thats make nothing.

There was a bug in one of the new features in 1.3.0. It has been fixed in 1.3.1 that is also available now.

1 Like

I'm loving Octoprint Dashboard, thank you!

I can't seem to get it to display my webcam though. Any ideas?
It's displaying this instead: Webpage not available

The webpage at could not be loaded because:


It appears the slash after 212 is missing if this helps.

I'm guessing it's hitting this code and there's no slash in between the two parts.

return window.location.origin + self.settingsViewModel.settings.webcam.streamUrl()

Yep, that looks like a bug.

That’s most likely it. You can add a leading slash to the stream url in the OctoPrint webcam settings while I fix this.
The default seems to be:


I don’t sanitise the input in case that slash is missing so that is what happened to you.

Please open an Issue on the project github so I don”t forget about this in the morning.

@OutsourcedGuru I there a better way to get the stream url that I have missed?

Edit: Nvm. It was a rookie mistake. It turns out I overcomplicated things. This will be fixed in the next release.