Detailed view not working?

I installed this plugin

Thinking I can see on my printer display the progress, but don't see anything.
Rebooted the Pi box, and printer.
Using the latest firmware on the machine (original)

I looked in Octoprint, and I see the screen for the options, and looks like everything is enabled.
What am I missing here?

thank you

Test that your printer supports sending messages using M117 by sending something like this:
M117 Testing and see if the word Testing appears on the printer's display.

Thank you.
I did remove M117 from some blacklist page in octoprint.

I need to find out how I can send those commands to my CR10s Pro V2

The terminal tab in OctoPrint, when the printer is not printing will allow you to type and send commands manually.

1 Like

ok, will check once the printing is done in 30 min

1 Like

i see

Send: M117 TESTING
Recv: ok

but nothing on the display :frowning:

Try to send it again in safe mode

Tried it in Safe Mode and the still nothing

Did you flash another firmware or is it the stock firmware?

stock firmware

It's possible the stock firmware doesn't support this, so you might have to look at flashing new firmware to the printer for this to work.

was afraid of that.

Thanks, I will look into the custom firmware

btw when I use octoprint, the display just stays normal in general with the icons.
I need to use my phone or web, to turn off the print in case i need too.

Any idea what firmware I would need for it to work ? I've tried several of these plugins as well, and still can't see any updates on the printer screen. I'm running the TFT 35 V3 from BigTreeTech. I've installed the latest bugfix (forget what version number it is). Thanks

Guess I am glad i didn't take my printer apart yet then, I was going to change the Firmware to the one from TM3D, but now I am not so sure.

I have a vague memory that the TFT from BTT uses a serial port to communicate with the printer, and have seen people with these kind of problems before. Something to do with the printer not telling the screen the message - can't quite remember.

@pka4916 it looks like the screen may be similar on yours, since it is touch/full graphic display. Some of them have their own firmware, which might not support receiving the messages from the printer. Hard to know really.

1 Like


Maybe there are other users with the same device, and know that.