Difficulty downloading plugins on OctoPrint

I have attempted to install them several times without success. I have tried four different methods:

  • Classic installation via the "Install" button in Plugin Manager -> Get More. This returns the error: "Unexpected error while trying to install plugin from None", "Install Unknown".
  • Installation via URL. The same error occurs.
  • Installation via the GitHub ZIP folder by downloading directly. Another error appears multiple times until it tells us that the Plugin is already downloaded (probably because I did this manipulation several times), and then it redownloads the folder until the installation is complete. However, the Plugin still does not appear in the installed ones and remains in the "get more" list.
  • Installation on the Raspberry with the "pip install" command. Same error as via the zip file."

Thank you for your help.

Please share more details. Things like how your OctoPrint install is set up, which plugins are failing, exact error messages shown.

Please share the systeminfo bundle - we need logs etc. to be able to tell what is going on in your system.

octoprint-systeminfo-20231221124500.zip (99.8 KB)
octoprint.log (584.7 KB)

Here are the different files requested.
The errors I'm seeing are in the file: plugin_pluginmanager_console.
Thank you.