Enclosure plugin button not worked

#1

What is the problem?

I downloaded the enclosure plugin to control the light.
There is an output button at the top, but it does not change to on when i press the button.
I have had the experience of making this a success.
But it doesn't work all of a sudden.
I think it should be switched on and off regardless of the raspberry pie when I press the button on the homepage.

What did you already try to solve it?

I reinstalled the octopi firmware.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

#2

안녕하세요 성훈.

Can you please share the Enclosure Plugin settings you made and the connection to the hardware (GPIO).

#3

Output Type : Regular IO
Label : Output 1
IO Number : 4

I connected Raspberry pi GPIO4 pin to relay.

#4

So, referring to the graphic, it's pin #7 on the connector. That's ok.

Can the relay board handle 3,3V control voltage?
The Enclosure Plugin has some advanced options.


In your case, take care that the Use Board Pin # check box is unmarked.

#5

Use Board Pin # check box is marked.
My relay board handle 3.3V control voltage.
Same Relay is being used for PSU CONTROL.
And PSU CONTROL button is worked.
If I give you my address, can you check enclosure plugin button?

#6

If you have the Use Board Pin # box marked, than you have to use 7 as IO Number.