Ender 3 V2 OctoPrint G4 P1 does not work

Hello, I have this problem on my Ender 3 V2, i filmed few videos with octoprint, now when I put to print the printer does not want to extruder, when I cancel G4 P1 code in my prusa slicer and put to print it prints normaly. With G4 P1 code it is printing but the extruder is not pushing the filament out the motor is not spining. What can be the problem?

Hello @ivo_derman !

Where in the slicer do you have the G4 command?
Keep in mind, that the parameter P1 only pauses for 1 millisecond:


On the video, the extruder is extruding, but also retracts again.
I assume, the hotend is at the desired temperature, so that it is not clogged.

no, extruder is not clogged it is problem in that code G4 P1 for sure the problem is here:
Right now I am printing this cube and it is printing beautiful:

and this is my prusa slicer settings : picture 1
and when i change this after layer change g code and add g4 P1 because I want to make octolapses the printer does not extruder any more! Everything is the same the printer heats up it starts to print is is printing correct but the extruder is not extruding it looks like it is clogged but it is not
picture 2

picture 1

picture 2

The question for me is:

What is the purpose for the 1 millisecond pause at layer change?

I dont know what exactly is the reason, I watched this video and this is what he does please check on 7:50 min

I see.

I assume that could be a firmware issue with the Ender 3

Maybe you change the value to 3 or 5.

The problem is because two weeks ago this worked perfectly and then one day it decided to not work any more I am trying this now for the last two weeks and dont know what to do, I reset the prusa slicer setting, I refreshed firmware on printer this morning and on display, I reset setting in octolapse and the problem is the same:/

what value to 3 or 5?

The P value in G4 P...

no still the same I tryed both G4 P3 and G4 P5:/

Could you enable serial logging, restart OctoPrint, recreate the issue, and then provide a systeminfo bundle as well as the octolapse log?