Extrudes Once With GUI & Once With Terminal

I disconnected the display from my Ender 3 Max (Printedweezl answer) which seems to have solved my printer randomly stopping midprint, I now have another problem. I'm going to run through the calibrations & have found that if I press the extrude button in the GUI it'll extrude once. If I send a G0 or G1 E command via the terminal it'll extrude once. Thats it, I can press extrude or send commands but nothing happens. I can send M92 or M851 etc & see the return, I have no trouble moving X Y or Z axis with GUI or terminal but to get the extruder to move again I have to turn it all off/on, reheat & then it does it once again. No problem with extrusion when its printing.
Any reason for this?

Ha. That's a new one :smiley:

Nothing in the terminal?

I fired up the printer & Octoprint tried to extrude with GUI & terminal, no movement. I'd enabled input shaping, loaded the firmware but forgot to do a G29 & save it. I did that & tried the extruder again, nothing. I entered the previous calibration settings for XYZE as well as the new input shaping numbers, saved them & now it's printing the second ringing tower. I know the XYZE calibration numbers are good as I'd not long ago done them, but the extruder was done via the now disconnected printer display. I can move X Y & Z axis with GUI & terminal, can't move the extruder

hmm try this before extruding:

G91 for relative positioning

Put it back to absolute positioning with G90 when you're done so you don't crash your other axis :slight_smile:

If you are in absolute mode and you give the command to extrude 5mm, it will extrude 5mm. Then if you give it a command to extrude 2mm, it will retract 3mm so that only 2mm of material is extruded. In relative mode, 5mm will extrude 5mm, then 2mm extrude another 2mm, for a total of 7mm extruded.

My guess is that you always tried to extrude the same amount which is means the stepper thinks it's already at the right location in absolute positioning mode.

The G91 got the extruder moving, it now moves with G90 & G91, it doesn't move via the GUI.
I set up another printer profile, still nothing from GUI.
If I G91 to get things moving I'll be able to calibrate the extruder for the different filaments, that's good enough. Yes you're right with your guess, I was using the same numbers :scream:
Thanks for your help

I can't find how mark it as solved

1 Like

Not sure why the gui doesn't work.
I'll try to check what OctoPrint is sending to printer late :person_shrugging:

All I can say is that it worked for me.

Ok thanks :+1: