File Manager Plugin not showing files?

Hi Folks,

I've just installed the file manager plugin and nothing's showing up there. What am I missing?

1 Like

I'm sure everyone who could help you would love to see your octoprint.log file's contents, minimally.

I've gone through the octoprint.log, but I'm not sure if it really helps at all.

octoprint (1).log (29.0 KB)

Here's a screenshot of what's happening. Neither the sidebar filemanager and filemanager plugin have any filters, so I can't see any reason it wouldn't be displayed.


I am here for the exact same issue. I can create a new folder (as can you from your screen shot) but it never shows up in the filemanager. it only shows up on the left hard side. It is the only thing that you can do in filemanager.

Anyone know whats up with it? I tried uninstalling and reinstalling to no avail.

There used to be a (side panel) File Manager's option ("Gear icon") menu which allowed you to toggle visibility of empty folders. There was also an open issue at that time in which people were debating about this.

Short version: remote into the Pi, find the ~/.octoprint/uploads area and your newly-created folder. Change into this folder. Then do a touch .flag command to create a hidden file in it. In theory, this would make the folder no longer empty and it might then show up in one or either of the File Manager places in the interface. If it doesn't, then feel free to rm .flag to reverse.

Or it may need you to place the first .gcode file this way for it to show up.

Im sorry I think you misunderstand. I have folder and files and none of them show up in the plugin filemanager.

However if I make a folder in filemanger it shows up on the left bar...just not in the plug in screen.

Maybe this will explain it better.

Your comments however did get me to play around with the gear icon inside of fileman.

If I change the view to "mixed" then I can see my stuff. This is not the view I prefer, but it will work for now I suppose.

1 Like

Sadly, nothing .... no file, no folders, nothing .... shows up in my file manager plug in.

Edit: I just switched to mixed sort order as well. That diaplayed my files, but clearly there's a bug there.

1 Like

Yes - it has been recorded as an issue on github

There is an update to this plug in released today and I can confirm everything seems to be working properly. This issue has been resolved! :slight_smile:

1 Like