Firmware Error 20

first time here
can't connect octoprint to printer Longer LK4, tried updating firmware. can't find what this error 20 is. octoprint says the error is from the printer's firmware.

Send: N0 M110 N0125
Recv: Grbl 1.1f ['$' for help]
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0
Recv: error:20
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

first time it happened i ignored the warning and it connected but since then it just won't connect even when i change the settings.

some help appreciated

Looks like maybe your printer is running on GRBL and not Marlin. GRBL will take GCode but I am pretty sure that Octoprint is expecting a Marlin based Firmware only at the printer end.

Does your printer work like it is meant to without using Octoprint? Did you mistakenly update your printers firmware with a GRBL firmware?

1 Like

i downloaded the firmware from maker's website directly. followed their instructions shouldn't be grbl that i know, i'll recheck. seems to work without octoprint, already printed something, just wanted to have it work with octoprint.

I'm making a Sand Table and I get the same error, did you resolve it?

I can run the Grbl command from Arduino no problem. It appears that the N110 command replys with an error 20. What command should I replace this with in the advanced connection settings under N110 handshaking please ???

I never resolved the error. I simply gave up, connected my printer to an old instance of Octoprint on my Raspi 4 and now it's good. The problem only appeared on my install of Ocotprint on a windows machine. Sorry but I don't know why that error showed up there.