[Firmware Updater] - needing settings for CR-10S Pro


#1

Hey, can anyone give me the specifics on configuring the Firmware Updater for a CR-10S Pro? OctoPrint can connect to the printer just fine. Flash method, etc.?

OctoPrint v1.3.10
OctoPi 0.16.0, running on Raspberry Pi 3 Model B Rev 1.2


#2

FIXED!

The chipset on my CR-10S Pro is the ATMEGA2560. For those of you unfamiliar with finding this, look at the top of the big black chip in the middle of your board, and that or something similar will be printed on it. The settings I used are as follows:

Flash method: avrdude
AVR MCU: ATmega2650
Path to avrdude: /usr/bin/avrdude
AVR programmer type: wiring

The firmware version I rolled back to (stock) is CR-10sPro_V1.60.3.hex

I tried updating to the TinyMachines3D firmware and it kept driving the nozzle into the bed when attempting to level. TinyMachines firmware updated the baud rate to 250000, and I originally used Cura to do the update, but it cannot connect at that high of baud, so would never reconnect. Seriously appreciate that this plugin was available!!


#3

I'm not convinced that "wiring" is the programmer type. I think I usually see this as "arduino".


#4

Those settings worked for me. The plugin author states on Firmware Updater that "wiring" is the common option for the Atmega2560 chipset. If you're not convinced then check the chipset documentation associated with your system before attempting. Again, this worked for me.


#5

Fair enough. I was under the impression that "wiring" indicated that you had a physically separate piece of equipment like an FTDI cable with a chip in it.