Firmware Updater not working

Trying to update firmware via .hex file. I have a 32-bit creality silent board. I have previously uploaded firmware via vs code and USB cord and hat al worked flawlessly. I have octoprint connected and everything set up as all the tutorials have. I have even tried doing it manually via ssh. here is the log.

Ocoprint connects via that baud rate so not sure about the issue. tried all other available baud rates just for good measure no luck.

Used a laptop matter this failed to update to tweaked firmware so vs code still works but I would love to just use octoprint in the future.

Hello @cardboardboxprocessr!

I don't think that 32 bit boards can be programmed with avrdude.
Have a look at the programming log in VS code when you programm the board from there. That shall give you a hint what mechanics are used for 32 bit boards.

For 32 bit Creality boards you should end up with a .bin file, .hex is for 8 bit boards. This file is then added to the SD Card and then the printer swallows it up and flashes it in a couple seconds on boot.

Edit: If you are building with PlatformIO or Auto Build Marlin, make sure you have the right board setup, the default Marlin config for some Creality printers is not for the V4 boards, you have to find the specific one which may then make it build in 32 bit style.

oh interesting where do I get the .bin? Mine does not seem to output one.

It will only output if it is setup correctly. Are you using PlatformIO on its own, or the Auto Build Marlin plugin? Other key bit of information is what version number is printed on the control board of the printer.

Oh umm this is the board should be v2.2.1 I know it says ender 5 board but it was cheaper than the cr-10s version which just had cr-10 firmware which I over wrote.

in vs code I just have the platformIO extension. I don't know anything more than that I am not relay a programmer or get compilers and such.

ATMega2560 is 8 bit, so you are back to square one with that one. It is possible the bootloader may have been overwritten when you uploaded the firmware, I have heard that can happen

This is not really an OctoPrint issue, while someone may be able to help, you might find people who know more on the Marlin discord, or other forums since that is their 'speciality'!

what do you mean back to square one?

As in, my help with .hex vs .bin is no use, you are back to the original problem

While we are on the subject, I put a new BTT SKR mini E3 V2.0 on my Ender 3 pro. The preloaded firmware works but it probably isn't the most up to date and the Arc function probably isn't enabled which is probably why arc welder sucks when I try and use it. I downloaded the most current bug fix version of Marlin 2.0 along with the configuration files, found the preconfigured files for the BTT SKR mini E3 V2 on the Ender 3 pro, copied and over wrote them sucessfully onto the appropriate Marlin files then opened the config files in VScode so I could enable arc function and compiled. I have a saved .bin file on my PC. It isn't really convenient to bring my PC and Printer together via USB cable as they are in separate areas of the house networked via ethernet. I could flash a microSD card and put it in the printer but all my microSD cards have stuff on them and I don't want to delete so I'd have to go out and buy another SD card. That is when I stumbled upon the firmware update plugin. Will this allow me to use my Raspberry Pi to update the firmware on the printer? I cant install the plugin presently because I am in the middle of a print with 10 hours to go. I am just trying to figure out if I should just go buy another micro SD card or if there is no need.

It might work, depending on the boards architecture. Have a look at the plugin's homepage for info. You may have to try it and see.

You don't have to flash the SD card (and erase everything else), if the SD card updating method is supported, the first, unique-named .bin file will be attempted to be flashed. So you can leave everything else on there (as long as they are not .bins too!)

thanks you for the reply. I'll give it a try. The goal is to get arc welder to work correctly. I have the new firmware for the BTT SKR Mini E3 on a creality E3 and I commented the Arc lines then compiled so it should be ready to put on the card and upload.

1 Like

Just browsed that link and the BTT SKR Mini E3 is not yet supported by this app. Thanks for pointing me in a useful direction. I have it on a micro SD card and will update once next print done.