FIXED: Octolapse not taking any snapshots - 'NoneType' object has no attribute 'find' error


#1

I'm probably missing something really basic but have no idea what

I started using my raspberry pi camera for 3d print live
streaming yesterday and it works fine for viewing in the control panel and
octolapse is happy when the test button is used on in the octolapse
camera settings. However, octolapse remains at snapshot count 0. When I look
in the log I find a 'NoneType' object has no attribute 'find' error
in reference to the URL. plugin_octolapse.log

The Pi is a Pi3 running raspbian stretch that I have installed
octoprint onto NOT running octopi. It is octoprint version 1.3.9. The
printer is a Creality Ender 2 Mini that I have modified the cr-10
octolapse setting to suit, my slicer is Cura

Octolapse settings.json (had to be renamed to settings.log to get past upload filter) (73.0 KB)


#2

I'd need to see your gcode to be sure, but my guess is there's an invalid character (at least as far as Octolapse is concerned) somewhere within the gcode file. If you want to post the Gcode, I'll take a look and will see if I can find the problem.

It's possible that this issue has already been taken care of by a re-write of the gcode parser itself. If you want you could update to the latest pre-release (over 100 updates ahead of the current stable release) via the plugin manager by using this URL in the '... From Url' field (this will become stale FAST): https://github.com/FormerLurker/Octolapse/archive/v0.3.4rc1.dev2.zip

Please note that you will lose any snapshot profile customizations you've made, and you'll have to copy your most recent slicer settings into the octolapse printer profile. Here is a brand new video to help get you running with the new version.

In any case let me know how things go and I'll do my best to help get things up and running!


#3

I tried to upload my gcode to here but it's just over the file size limit, I did also email you about this yesterday and attached the gcode to that. gcode in google drive
Thanks for answering!


#4

I've been in contact with @FormerLurker over email and it turns out my gcode was missing a G90 in the start gcode and he also recommended using the latest rc. I am pleased to report that this has fixed my problem. I can recommend the latest rc to people as it is a vast improvement on stable with slicer specific setting names being the main improvement.


#5

Nice!

Could you please check the small checkbox below your last post marked Solution?
It's more easy to keep the overview. Thanks a lot.


#6

I was looking for something like that but couldn't find it. Done.