Flask in plugin requirements?


My plugin requires flask>=0.10.1 which should be fine as it's also a requirement for OctoPrint.
But yesterday, I've had someone getting my plugin to crash. Because they were using flask 0.10 with OctoPrint 1.3.10.

My question is : Is it safe to add flask>=0.10.1 in my plugin requirements or can it add possible compatibility issues ? (ie: with future versions)