FLSUN QQ-S some problems

Can anyone tell me if Octoprint is compatible with FLSUN QQ-S ?,
Today I connected the printer to octoprint, it started printing and after a while the printer did not move anymore and quickly canceled the print and sent home.

Hello @Matias_Suarez!

Please do not delete the template. The required information are vital for dealing with your problem.


What is the problem?

What did you already try to solve it?

Logs ( octoprint.log , serial.log or output on terminal tab at a minimum , browser error console if UI issue ... no logs, no support! )

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible )

octoprint.log (111.5 KB) serial.log (444 Bytes)
FLSUN QQS
Octoprint 1.4.0 stable

ver 2.3
MKS robin mini

So, sadly, the serial.log was not activated.
From the octoprint.log it seems you have communication problems with the printer:

| Trying baudrate: 115200
| Recv: E.½r'ÔKµa*ÉrK5
| Send: N0 M110 N0*125
| Recv: C!UÍe‹é1C¡k«Hø
| Recv: Resend:1
| Recv: ok
| Changing monitoring state from "Detecting baudrate" to "Operational"
| Send: N0 M110 N0*125
| Recv: 
| Recv: Resend:1
| Recv: ok
| Send: N1 M115*39
| Recv: 
| Recv: Resend:1
2020-03-06 12:50:39,323 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 1, current line = 2
| Last lines in terminal:
| Starting baud rate detection...
| Changing monitoring state from "Opening serial port" to "Detecting baudrate"
| Trying baudrate: 115200
| Recv: E.½r'ÔKµa*ÉrK5
| Send: N0 M110 N0*125
| Recv: C!UÍe‹é1C¡k«Hø
| Recv: Resend:1
| Recv: ok
| Changing monitoring state from "Detecting baudrate" to "Operational"
| Send: N0 M110 N0*125
| Recv: 
| Recv: Resend:1
| Recv: ok
| Send: N1 M115*39
| Recv: 
| Recv: Resend:1
| Recv: ok
| Send: N1 M115*39
| Recv: 
| Recv: Resend:1
2020-03-06 12:50:39,333 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 1, current line = 2
| Last lines in terminal:
| Send: N0 M110 N0*125
| Recv: C!UÍe‹é1C¡k«Hø
| Recv: Resend:1
| Recv: ok

The scrambling seem to repeat, so try another baudrate manually. Also have a look at this: OctoPrint randomly loses connection to the printer with a "SerialException"

Also this:

2020-03-06 14:06:46,465 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

You should check your power supply. Please do not use a charger for the Pi.

1 Like