G34 - Z Steppers Auto-Alignment contol panel button

Hi to all devs and those that have the power of coding skills.

I am poss too late for this as it may have been suggested already and been included in the latest test builds (I live on the stable branch) but if not, here goes.

A few months ago I learned of a nice little gcode command to align dual independant controlled Z axis steppers (G34 - Z Steppers Auto-Alignment)
would it be possible to add a button on the control settings page that will start the G34 command running ?
Since there are already home options for XY & Z It would be the best place for little button to do said G34, It could be enabled in setting to be added if required

I have no idea how hard or easy this may be but it may come in handy for others.

If I am too late then just let this die and fade off into the past.

Thanks to all the devs for the work you have done.

There's really no need for an additional plugin or custom code, the controls are actually customizable. You can add your own as described here:

There are other examples here:

There's also a plugin for creating custom controls without having to edit the file directly:

Cheers for the speed reply.
I have had a tinker about with the custom control plugin and it does let you add custom commands to the control panel as it`s name suggests and I have added a simple button saying G34 that sends the G34 command and it works as it should. this does not need to be a stand alone plugin or script or anything as complicated as that I was just asking if maybe it could have been added to the original code that lives in the same area as the built in commands. Using the custom controls means they are not include in the same area as the supplied commands but are added after them unless I have missed something ( A nasty migrane is comming in and screen reading is starting to hurt my eyes so I will need to come back to this later) Thanks again for your quick reply TTalkington

Problem with that is not all firmware supports the command, it has to be enabled in Marlin, etc. Anything that does not work for the majority is best suited as a custom control/pliugin implementation.

Kinda thought that Jneilliii. I have tried the custom control plugin and it works that is untill I power off the system for the night, The next power up on the system the command is gone.I know my setup is a total mess with plugins and prob tweaks to the ui that break things that should not be broken but it happens everytime I power off the pi. config.yaml just seems to reset back to a point before the command was added. I did back up the file so I have a working base. then I added the command from the plugin then backed up config.yaml again to see if it was working ok (and it is as I can see the entry), it works fine as it should for the rest of the day or untill the pi is power cycled and after it`s started up again the command is gone and config.yaml has reverted to the original pre command state. Unfortunatly I have too much on at the moment to dig into this deeper so I will do without and just change to terminal to send the g34 command.

Unfortunately that's a known issue with that plugin that hasn't been patched yet, as the plugin author is not active.

See this comment for a fixed version:

Otherwise, once you have setup your custom controls you can disable the plugin and it should not clear them out again.

Thanks @Charlie_Powell. I have finnished of a slight redesign on my upgraded Ender 5 ( Now an Ender 5 Max) and now I can test out both the fixed CustomControl and the printer together. thx again

1 Like