Got RTSP on octopi working

I'm not sure if this would help anyone but this is how i got rtsp working on octopi after installing the new image with the new camera stack

  1. log in to pi via ssh
  2. sudo systemctl edit camera-streamer-libcamera --full
  3. add the line --rtsp-port=8554 \ on a new line before ${OPTIONS}"
  4. save
  5. sudo systemctl daemon-reload
  6. systemctl restart camera-streamer-libcamera.service

now i can see my prints in frigate :slight_smile:

You can add this to the config files in /boot/camera-streamer/* for your cameras, in the OPTIONS section. Then you don't have to edit the service files, the config files provided are meant to be able to add these options.

1 Like

Ohhhh! i see! i saw those ${options} in the service file but wasn't sure where i could edit those. thanks charlie!