GPIO Shutdown plugin not able to activate

First I want to say OctoPrint is the greatest thing I have done to my printers, thank you.

I have two Aquila printers both running OctoPrint on Pi 4s. I installed the GPIO Shutdown on one yesterday and everything went as advertised, works great. This morning I installed it on the second printer but it didn't go real well. It looks like it installed ok but it is grayed out in plugin manager and refuses to activate. I don't understand Unix at all and have no idea what to look for ln getting it working. Help!

Both printers and OctoPrint installations are pretty much identical.

Could you upload the systeminfo bundle?

Didnt try but did install the tune up group plugin and it is working. Will look into your suggestion and see what happens. Right now I don't even know what system info bundle is.

OK, now I know what it is, when I get back out to the cave I will follow up with more info.

Click the link, and follow the instructions. Download the zip file and upload it directly to the forums. You can find the system info bundle here (also instructions in the links):

Now if I can figure how to upload it to the forum? (231.7 KB)

Thinking about this I may have shot myself in the foot. I installed it then didn't see it in Plugin Manager so installed it again which might have screwed up the works. I uninstalled it yesterday and will Install it again when I finish this and see what happens.

No go same result, grayed out

Hello Bob,

octoprint.log has this to say about the GPIO shutdown plugin:

2021-12-01 01:11:45,447 - octoprint.plugin.core - ERROR - Exception while initializing plugin GPIOShutdown, disabling it
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/", line 1984, in initialize_implementation
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 1737, in wrapper
    return f(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 1737, in wrapper
    return f(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 1737, in wrapper
    return f(*args, **kwargs)
  [Previous line repeated 2 more times]
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_GPIOShutdown/", line 29, in initialize"Running RPi.GPIO version '{0}'".format(GPIO.VERSION))
AttributeError: module 'RPi.GPIO' has no attribute 'VERSION'

and, true to it's word, it lists this plugin as disabled

| !GPIO Shutdown (1.0.4) = /home/pi/oprint/lib/python3.7/site-packages/octoprint_GPIOShutdown

Later you try your luck with the calibration companion plugin and run into errors, too:

2021-12-01 10:08:16,833 - octoprint.plugin - ERROR - Error while calling plugin calibrationcompanion
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/", line 271, in call_plugin
    result = getattr(plugin, method)(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/", line 1737, in wrapper
    return f(*args, **kwargs)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_calibrationcompanion/", line 226, in on_event
    if payload['name'] == self.filename + ".gcode":
AttributeError: 'calibrationcompanion' object has no attribute 'filename'

Now, version, filename, those sound like really basic attributes and the object not to have those may actually mean: it does not exist.

I have no experience with those 2 plugins but looking at you plugin list I wonder if you can install any 3rd party plugin on that system at all.

If it was my box I'd simply try to install a few and then take a close look at the octoprint.log

Thanks for looking into this for me. Think I will just start over from ground 0 with a new installation of OctoPrint on a new SD card. No reason it shouldn't work as well as my other one. I may have done something stupid along the way and just maybe a new installation will fix it. This was the first one and my first time installing OctoPrint.

That fixed it, finally have all the issues with Octoprint resolved, Cura is working, GPIO shutdown is working, life is good.
Basically I started again from Ground 0 with a new SD card and fresh installation of Octoprint. Installed GPIO shutdown and it went just like it was suppose to. Happy Day...

Thanks gang for all your help