HA MQTT Command

Hi there,

I used the MQTT HomeAssistant plugin to send a MQTT command from HomeAssistant to OctoPrint to establish the connection to the printer. Since the Octoprint Update to 1.9.0 this command is ignored/ misunderstood:

octoprint homeassistant ERROR - Unknown message received: b'on'

Any other MQTT topic seems to work and manual printer connection via webfrontend button as well.

Any help would be highly appreciated,
thank you!

Hi there
I'm not sure on which side the error is.
Please upload a systeminfo bundle so we can see what's going on.

edit: it seems like other features also stopped working for this plugin since 1.9.0.

I think it would be the best if report your issue at the plugins github

I just created a fork and patched the changes described in this issue. Install by copying/pasting the URL below into Plugin Manager > Get More > ...from URL and click install.

1 Like

Wow! You are all so super fast - thank you! :kissing_heart:

@jneilliii So this means with your patch I could get it working again? Sorry - I am really a noob in here… :see_no_evil:

@PrintedWeezl Should I still report to the GitHub plug-in section?

And sorry (again) for forgetting the system info bundle: here it comes if still needed?

octoprint-systeminfo-20230618064046.zip (59.3 KB)

1 Like

Actually, I think I patched the wrong spot. Give me a few minutes.

1 Like

Sure - you have a lot of hours (from my side) as the print I started when observing the plug-in problem ends only in 15 hours …


I think this one will fix it. If it does, please let us know and I can submit a PR to the official repo.



WORKED like a CHARM :slight_smile:

Tank you very much!


That's good to hear. I actually took out the OctoPrint version compatibility checks as it seems this may not be the reason it wasn't working. I've also downgrade OctoPrint to 1.8.7 and the patched version still works, so this must be related to a change on the HA side.

Okay, I see - so do you think I should post this to HA forums (tagged MQTT)?

I'm not actually sure. The switch may have never worked and was just never reported.

Actually it did work: I often used it!

Yeah, I tested later the older OctoPrint version with the original and it definitely was working. I ended up adjusting my patch/PR to adjust based on OctoPrint version >=1.9.0 to use True/False, otherwise use on/off like before. Just needs to be merged and released by gruvin at this point.