Helloworld plugin is not loading in (venv)


#1

I am trying to follow the tutorial, and believe I messed something up. When I first installed everything, I was not able to run command

source venv/scripts/activate

and not knowing any better, I continued along the tutorial path. Couple things are happening. First the URL in the title bar never showed as indicated. I could see all the log entries though. In my effort to fix this I thought maybe it was because of the above issue. So I ran that command, and restarted the server. Now the plugin does not seem to load at all. No log entries either. So to fix that, I thought I would have to install the plugin again and so I re-ran the install command.

octoprint dev plugin:install

It got some errors (unfortunately I did not copy them) so I figured it did not work completely. But it did not change anything with regard to the plugin loading. At this point I exited Git Bash (on windows) and restarted. The (venv) indication on the prompt was gone, so I restarted the server. The plugin loads again (still no URL or settings dialog), and if I run activate script again it again does not load.

How would I get the plugin to be recognized after running the activate command?


#2

Update to previous post. It seems the plugin, while being recognized according the log file, is not actually running in Octoprint. I do not get any indication that the development environment is active either (I am expecting to see (venv) at the git bash prompt as shown in the tutorial documentation. When I re-run the plugin install it get a windows access denied error. I clipped the output below. Any help would defitnitely be appreciated.


Engineer@Leonardo MINGW64 /c/Devel/octoprint (master)
$ octoprint dev plugin:install
>> c:\python27\python.exe -m pip install -e .
Obtaining file:///C:/Devel/octoprint

...

Installing collected packages: OctoPrint

  Found existing installation: OctoPrint 1.3.6

    Uninstalling OctoPrint-1.3.6:

      Successfully uninstalled OctoPrint-1.3.6

  Running setup.py develop for OctoPrint

Exception:

Traceback (most recent call last):

  File "c:\python27\lib\site-packages\pip\basecommand.py", line 215, in main

    status = self.run(options, args)

  File "c:\python27\lib\site-packages\pip\commands\install.py", line 342, in run

    prefix=options.prefix_path,

  File "c:\python27\lib\site-packages\pip\req\req_set.py", line 795, in install

    requirement.commit_uninstall()

  File "c:\python27\lib\site-packages\pip\req\req_install.py", line 767, in commit_uninstall

    self.uninstalled.commit()

  File "c:\python27\lib\site-packages\pip\req\req_uninstall.py", line 142, in commit

    rmtree(self.save_dir)

  File "c:\python27\lib\site-packages\pip\_vendor\retrying.py", line 49, in wrapped_f

    return Retrying(*dargs, **dkw).call(f, *args, **kw)

  File "c:\python27\lib\site-packages\pip\_vendor\retrying.py", line 212, in call

    raise attempt.get()

  File "c:\python27\lib\site-packages\pip\_vendor\retrying.py", line 247, in get

    six.reraise(self.value[0], self.value[1], self.value[2])

  File "c:\python27\lib\site-packages\pip\_vendor\retrying.py", line 200, in call

    attempt = Attempt(fn(*args, **kwargs), attempt_number, False)

  File "c:\python27\lib\site-packages\pip\utils\__init__.py", line 102, in rmtree

    onerror=rmtree_errorhandler)

  File "c:\python27\lib\shutil.py", line 261, in rmtree

    rmtree(fullname, ignore_errors, onerror)

  File "c:\python27\lib\shutil.py", line 261, in rmtree

    rmtree(fullname, ignore_errors, onerror)

  File "c:\python27\lib\shutil.py", line 266, in rmtree

    onerror(os.remove, fullname, sys.exc_info())

  File "c:\python27\lib\site-packages\pip\utils\__init__.py", line 114, in rmtree_errorhandler

    func(path)

WindowsError: [Error 5] Access is denied: 'c:\\users\\engineer\\appdata\\local\\temp\\pip-wzfuld-uninstall\\python27\\scr</code>ipts\\octoprint.exe'



#3

Discussion continues in this topic.


closed #4