Help! Trying to load a plugin

This was an earlier post combined with another, so I am reposting it separately.
I am modifying a plugin and am trying to load the modified plugin. I can load the plugin, but the configuration settings don't show up in the Octoprint settings. Therefore, in an attempt to figure out what is wrong, I went back to the ORIGINAL WORKING PLUGIN (GPIO Shutdown-loaded it via the Plugin Manager from the Octoprint catalog-and working correctly) and tried to load it from Github. Here's what I did:

  1. I downloaded the zip file and loaded it into the Plugin Manager. The Plugin Loaded correctly, but the configuration settings didn't show up. In fact, the configuration screen was blank.
  2. Tried to load the plugin from the URL in Github. The install got the error:
    Installing plugin from
    Could not install plugin from, was neither a plugin archive nor a single file plugin

My question: How do I install a plugin for testing (not going through the Octoprint catalog)?

octoprint.log (16.2 KB)

this issue is because you were using the git clone url, not the download url...

I tried to load it using the URL for the, and have the same issue that I had when I downloaded the zip and installed it using the Plugin Manager--Configuration screen is blank. When I install the Plugin using the Plugin Manager and get it from the Octoprint Catalog, I get the proper configuration parameters in the Configuration Screen.

I'm obviously not doing something correctly. Help!

I should be able to download the .zip file and load it into the Plugin Manager, but it doesn't work properly.

Are you running octoprint 1.5.0? there may be a knockout binding issue with the plugin.

let me install on my side and see what's going on.

Ok, after installing the plugin, I noticed it only was showing reload, not restart octoprint but it actually needs to restart in order to load the new templates that is uses for settings. Once I restarted OctoPrint I then got the settings interface to load fine.

That worked, thank you. THe Octoprint message should have restarted Octoprint.
Anyway, I downloaded and installed my modifications, and they worked perfectly. I can now shot down the printer and power supply when I push the button.

1 Like

I am now at a loss as to what to do. I can merge my fork back into the original plug-in, but I emailed the original author of the plug-in asking him what to do, and, after several days, I have receive no response.

My question: Should I merge my changes back into the original plugin, Or create my own plug-in? Or do nothing. The original plug-in also has some documentation errors. If I merge my changes into the original plug-in (or create my own), how do these changes get migrated to the Octoprint catalog.

Typically you would submit a Pull Request (PR) against the original repository if the changes you've made fix stuff. That way the original author has the opportunity to merge them. There is a procedure for adopting/taking over maintaining a plugin, but will require a little work on your part if you do want to take over that role. First submit an issue on the original plugin's repository requesting that they merge your PR. If after 14 days there is not response from the original plugin's author you then submit an abandonment issue at, completing the requested information on the ticket for the link to your issue in the original plugin repository, etc. After review/approval you'll need to then submit a PR against the repository where you filed the issue with the necessary changes to point the plugin repo to your fork on github, which would also need to be updated for the software update check and a new version bump release with those changes incorporated.

It sounds real daunting, but it's not really that difficult.

Thanks. I just submitted a pull request. Let's see if the author responds.

Also, how do I take over an abandon plugin? I am tired of seeing the messages when I log into Octoprint. The plugin is Automatic Shutdown, which I find very useful. The original author did the shutdown correctly.

Similar process as explained above. There is an issue already posted for this one, but no-one has done all the other parts that are necessary. The only difference here is that @foosel has control of this plugin as it's part of the OctoPrint organization and therefore could be given you permission to maintain. Looking at the plugin's repo, it appears there is a PR and issues listed for Python 3 compatibility requests since June so I think we can say with fairly good certainty that this one is Abandoned.

Ok. I could do a PR, but there really isn't anything to change. It works perfectly as is under PY 3. I could take it over, but there really isn't anything to do. It really should be part of the base Octoprint.

Not really, since not everyone wants this feature & it is clearly easy to do from a plugin. Plugins are just so much easier as it releases pressure on Core OctoPrint maintenance to fix issues etc., and can be released on a different cycle to OctoPrint as well.