How are you guys getting perfectly centered Octolapse timelapses?

Looking at other Octolapse timelapses, I see perfect videos, with the extruder basically locked in place in the frames as the print goes up. However, regardless of what settings I use in my setup, the extruder either sways like a drunk or walks around. I have tried all of the Smart triggers with Centered stabilization, and the best I have ever been able to do is this print. This print from today is a perfect example of the issue I'm seeing (ignore the issues with the actual print). Can anyone who has figured this out shed some light? I have spent a significant amount of time trying to figure this out and don't appear to be getting any closer.

This is on a Voxelab Aquila X2 printing to OctoPrint 1.9.3 on a Raspberry Pi 4 running the latest build of Octolapse (happened on the previous build, as well). Slicer is OrcaSlicer 1.9.1.

It's probably worth you sharing your current "Stabilisation" settings so that people can suggest improvements.

If you want it perfectly centred, make sure you're not using any "snap to print" settings, and if you're getting some jitter in the timelapse then you might have to increase the picture taking delay to account for the slow camera.

I have mainly used the default Stabilization setting of Centered, but have also played with Center Left; both exhibit the same behavior. As far as delays are concerned, my PiCam v2 is configured for a 50ms snapshot delay and 5000ms snapshot timeout.

Also, I'm not sure that this has anything to do with the snapshot delays. I have Snapshot Plan Preview enabled, and you can see the extruder moving around in the preview, which is what I wind up seeing in the actual timelapse. That's why I was wondering if something in my slicer needed to be modified.

It looks like the last move on each level isn't ending up in a pre-defined place. This will be even more obvious if you choose random Z layer changes to mix up any over-extrusion dribbles. Otherwise you will probably find it prints a visible line of over-extrusion on the surface when it changes to the next layer.

What I did was to "park" the head at the back left before taking a snapshot. That way it is in a pre-defined position prior to taking the snapshot, not hoping the last move of a layer will stack up in the same position each time.
It does take slightly more print time with the move away and return, as well as the possibility of stringing. The positive unintended consequence of that is that over-extrusion blobs don't appear on the face of the model, instead being converted to stringing as it moves to the rear.

I'd be open to trying that method. How did you configure that? It sounds like what the "Back Left" Stabilization in Octolapse is, but I'm not sure that would work given that "Centered" already doesn't work for me.

My Octoprint doesn't want to run for me at the moment so I can't check (corrupt card?, I have a backup somewhere). That sounds familiar, the back left option. I chose that option to get the head out of the way so a full shot of the model can be taken without the top being obscured. I also think I played with adding a pause after it parked there, the thinking was it would allow time for the platform and head to settle down and eliminate any shaking. Turns out I didn't need to do that, it was pretty stable without a delay. Perhaps you could add the delay and keep it in the centered position if that works for you. Again from memory, it was a pretty short time, 150 or 200 milliseconds should be plenty. I'm not sure if your odd captures are happening early or late, so you could try adding delays before and after the snapshot command.

OK, got it working now.

  • Under the Octolapse tab, select the camera you are using.
  • Edit the profile for the camera (the pencil icon)
  • Scroll down to general options
    Here you can add a delay before the snapshot is taken.

It's a weird place to put the option in my opinion, not very intuitive.